Can't modify hard drive icons


I can't seem to change the default hard drive icons. I have tried copying and pasting the icons using inspector, however it doesn't work. (Interestingly enough, when I boot up in OS 9.1, I can see the icons that I pasted, just not in OS X. The icons I'm using are for OS X, 128x128) I can however change icons on folders and other files. In addition, I have tried following the instructions on to modify the system icons, however i can't seem to get it to work. I am running build 4K78 on a 500 Pismo with 256MB of RAM. (I would like to put an icon of my PowerBook on my OS X partition!) Any help would greatly be appreciated.


I have roughly the same configuration as you do... I have had the same issues. I currently have been able to change the icon for my hard drive on the desktop. I did a "get info" on the drive and cut and pasted the image. It did not change immediately. I had to log-out and log-back in.

Under the finder I cannot change the image... it will not let me select it at all.

Pretty strange.


Ditto... But on a G4 450/DP 448MB RAM w/OS X build 4K78.

Found that an alias of the drive on the desktop updates immediately. Dragging the same alias to the dock shows the new icon on the dock but it looses the icon on reboot or logout/log in (not sure exactly when this occurs).


The same issue has appeared on the forums at I guess we are out of luck for now until someone discovers a hack....