Can't move 10.1 from one Hard Drive to another

thorman

Registered
I bought a new 60 GB IDE Hard Drive to make a little room for iMovie. I set it as the new Master drive, and set the Apple 10 GB Hard Drive as the Slave. So far, no problems.

I booted via my Mac OS 9.0.4 CD, and copied all my files from the 10 GB drive to the 60 GB drive, then tried to boot off 10.0.4 on the 60 GB drive and I got a 'Broken folder' icon - wouldn't boot.

So... I looked for invible files and found them! Copied those over too and tried to boot - same 'Broken folder' icon.

I then upgraded to 10.1 on my 10 GB Hard Drive, tried it again - same error.

Any ideas how I can copy my 10.1 installation from my slave Drive to my Master 60GB Hard Drive so that I can boot from the Master Drive?

Ahhh... The days of OS 9 when you just had to copy a system folder....
 

ksv

web developer
Try the Apple Software Restore app. Find it on a software restore CD or somewhere on the internet, start from a CD or an external disk that has ASR on it, drag the slave drive over to the ASR icon, and then select your options. Yes, this will erase everything you already have on the master drive, but I think that is the only way to completely copy a Mac OS X system.
 

baur

Registered
As far as I can tell by poking around the UNIX-ish files floating around the filesystem, it seems like you should be able to do it as long as you edit the proper files pointing to where the boot partitions are. Unfortunatly, most of my experiance lies with Linux, which uses a different naming scheme for devices and I haven't bothered to try and figure out what OS X uses.

Hopefully, someone will document that, and which files to change, at some point. :)
 

~vert

It's short for vertigo...
The work-around that I use is to install a fresh copy of OS X and then move over only your User, Library (the one at the root level), and the root level Applications folder (if you have stored anything in it).

So far it has worked without issue. I have all my prefences in tact, etc. I will caution to check folder size after the move to before. For some reason last time some folders associated with Mail.app didn't copy over. Lost one of my mailboxes and related messages. Didn't notice until after I had erased the original partition, of course :p

I assume there might be limitations to this if you have done some custom UNIX installs like XDarwin, etc.

Another thing you can always try is to reinstall OS X over your new install (the one you copied over). It should just update missing files and not touch any of your settings. Just be sure you don't select the option to do a clean install or it will erase everything.
 

baur

Registered
How did you do the copy? (ie: as root in OS X finder, using the command line or in the OS 9 finder)
 

~vert

It's short for vertigo...
Actually it is easier to avoid all that 'root' and 'privileges' stuff and just do it booted in OS 9. Kinda cheating, but it avoids all the UNIX gobbledygook.
 

jove

Member
Hello,

Do the links copy over correctly? Do they point to the new files?
 

thorman

Registered
I wasn't able to do the transfer - I could not, for the life of me, find the correct version of Disk Copy. I scoured the web with google & altavista - nada.
 
Top