Can't send mail using Eudora 4.2.2 in X.1 classic?


I haven't been able to figure out how to get Eudora (4.2.2) to send mail consistently in Classic mode (system 9.2 within X.1, on a G4 DP). (I'm unwilling to switch to Eudora's beta for OS X yet: it's not polished enough (crashes) to pay for, and I'm not ready to tolerate its ads on the desktop.)

I've narrowed down the problem, a bit: Eudora receives mail just fine. It sends short emails (several sentences). But I can't send a relatively long email (e.g. 10 paragraphs of several sentences each). It tries to connect to the SMTP server, then fails.

I've tried significantly extending the "response from server" time in the "timeouts" preference, to no avail.

Here's a typical Eudora log message:

Mon Oct 01 13:19:14 2001
102 1:17.30.51 25
102 1:0.0.46 Sending Shelly Kraicer, 13:11, failed mail.
102 8:2.0.44 TCP/IP Error.
102 8:2.0.45 -3162
102 8:2.0.45 The server is not responding.
102 8:2.0.45 {37:1330}
102 8:2.0.45 ÒTCP/IP Error. -3162; Ó ÒThe server is not responding. {37:1330}Ó
102 8:2.0.46 DATA
102 8:2.0.46 SMTP
102 8:2.0.46 ÒI said: DATA
And then the SMTP server said: Ó ÒÓ
102 1:2.0.46 Failed (602).

Just as a control, I've succeeded in sending long emails via the new mail app.

I wonder if it's a specific conflict between Eudora in classic and my ISP: I'm using Sympatico's "high speed edition" DSL (PPPoE) service?

Has anyone else solved (or even seen) this problem?