Can't serve webpages from Ti since upgrade....

bebox

Registered
Hi All,
Just trying this post again...
I am trying to allow clients to see webdev stuff that I am working on my Ti. Everything works fine locally (127.0.0.1) and no problems at all. But if I give my IP to a client so they can see their work in progress noone seems to be able to connect at all. They cannot ping the address and I ran Portscan and there are no ports open even though I have port 80 option in httpd.conf in Apache. So that seems to be the obvious problem but I cannot find a way around it!

Are there some other settings that may have been changed by the OSX upgrade. I used to be just able to give the IP and then away we went. All sharing is enabled and everything obvious seems okay.

Please help as this is killing me ;))

Thanks
 

attackwolf

Registered
It seems that apple made a few changes to apache due to the HFS+ bug. Here's the fix that someone generously posted to www.macintouch.com:

"Replace the existing file "/etc/httpd/httpd.conf" with the file "/etc/httpd/httpd.conf.default". Apple has renamed the HFS Apache module and the configuration file needs to be updated to reflect this change. "

to do this:
First turn off web sharing in the System Preferences.
Then from the terminal you can type:

mv /etc/httpd/httpd.conf /httpd.conf.pre_macosx10.1
mv /etc/httpd/httpd.conf.default /etc/httpd/httpd.conf

The first statement remains your old settings and the second statement renames the new settings so that Apache will use them.
If you had custom Apache settings and you don't want to retype them all, you can see that apple only made 2 changes to the file. (Again this bit of info I found on Macintouch)

LoadModule apple_hfs_module libexec/httpd/mod_hfs_apple.so

to

LoadModule hfs_apple_module libexec/httpd/mod_hfs_apple.so

or at the terminal type:
diff /etc/httpd/httpd.conf /etc/httpd/httpd.conf.default
and the diff program will show you the differences.

My apologies for not crediting the original authors but I didn't save their entire messages with names.
Good Luck
Chris
 

bebox

Registered
Hi Mate,
Thanks for the posting..
I spose I should have mentioned that I had already fixed that in the httpd.conf and to no avail. The problem seems to be in that something is keeping the ports (particularly port 80) from being open and thereby letting anyone in at all.

Thanks again and if you think of anything else please let me know :))
 
Top