Can't Wake From Sleep under 10.1

Chris Lepore

Registered
Under previous versions of OS X, I found my Lombard would fail to wake from sleep about one time in four. The keyboard would be somewhat responsive, but the screen would stay dark. At least I could give it the three-finger salute and restart.

Now, after upgrading to 10.1, it won't wake from sleep at all. The keyboard is completely unresponsive, so the only way to restart is to reset the Power Manager.

Does anyone know of a solution or workaround? It's going to be really annoying if I have to shut down every time I leave my computer.
 

Hobeaux

Registered
I noticed on occasion that my tangerine iBook would go to sleep and nothing that I would do would wake it up -- until I plugged it back into the wall. At that point, it immediately woke up.

It turned out that the ibook was completely out of juice.
 

mudmonkey

Registered
Chris,

I am having the exact same problem with my Lombard. It will NOT wake from sleep. I have to use the reset button in the back (not even the three finger power salute will reboot it). Then, the hard drive is corrupted. I have to boot from CD, change the startup partition to my classic partition, rebuild the desktop, remove mach.sym, and finally change the startup partition to the 10.1 and reboot. Then, the computer works great. Until I put it to sleep.

What is wrong here? I am going to post on Apple support boards. I tried 5G24 and it slept and woke perfectly, no problems (like you, I had many problems with sleep in 10.0.4).

For 10.1, I wiped my hard drive clean, installed 9.2.1, 10.0.0, then the 10.1 upgrade. So, there is nothing peculiar about my setup.

I'll let you know if I find anything.
 

Chris Lepore

Registered
mudmonkey,

Try zapping the PRAM. This seems to fix it ... unless you sleep the 'Book with an external USB device plugged in. Then when you wake it, USB is lost and the freezing recurs on subsequent sleeps. I suppose you can work around this by unplugging external USB devices before sleeping.

Instead of doing all you described, you could try resetting the Power Manager, cold-booting, zapping PRAM and starting in single-user mode (Cmd-S). From there do an fsck -y until it tells you the disk is OK, then Ctrl-D to continue booting into OS X. This works for me.

Chris
 

mudmonkey

Registered
Chris,

Thanks for the update; however, it is no go for me. It still will not boot after resetting the power manager and zapping the pram. I have to go through the annoyances of booting into OS 9 to get it to work.

It tries to boot, but, then, shows a torn system folder and just sits there forcing using the hardware reset.

Once I get it working again, I'll see if sleep works; however, I always have USB devices, and it is stupid if I have to disconnect them.

Good ol' Apple, it worked fine until they f***ed with it.
 

pollen

Registered
This is a known issue to Apple.
Atleast with Powerbook G3 that is.

Apple suggest pressing the brightness key on your keyboard to wake it up.

I don't experience the problem myself which means I have no clue of the validity of this tip.
 

Iuis

Registered
I had the same problem with my PBG3 and pressing the brightness key on the keyboard solved the problem:)
 
Top