Carbon apps dying!


usin UNIX since '92
The carbon apps on my oft-used MacOS X box are dying.

First MS InternetExplorer ceased working, then iCab and StuffIt Expander. They just don\'t start up.

Using the dock or accessing directly produces the same results. The app begins starting, appears briefly on the dock and then dies. I have not seen anything on the log (I use BetterConsole) and using \'open\' on the command line doesn\'t give errors.

Using a different user or version of the software does not work... I have only got some stuff to work opening them as root.

Has anybody experienced the same problems?

Yeah, I\'ve had the same (or similar) problem. Only, it\'s not just Carbon apps, now. Most Carbon apps don\'t work, but a lot of Cocoa apps are now doing it. Logging in as root seems to be the only thing to do. The problem, for me, showed up just after I went through the computer and set all the permissions up for FTP access. Anywho, I\'ve tried creating a new user, no dice. I\'ve tried reinstalling X, no dice. I fear the only thing left is for me to do a clean reinstall *sob* but I don\'t want to do that, cause of course I\'ll lose everything. Anyone got any ideas?
It sounds like a problem with file permissions. I had an app that behaved like this and its file permissions were screwed up. I changed them by logging in as root and the app launched fine.

Hope this helps :),
Right, that\'s what I thought. I mean, I dunno. I\'ve checked, and my entire hard drive is now set to read and write for all, so it shouldn\'t be a problem... but yet, strangely, it still is.
You have to use the terminal and the chmod command to give them execute permissions.

Use man chmod for details,
I\'ve been getting exactly the same problems as Dani++ and StormSilver (see my \'Can\'t Launch Some OSX apps\' post). Again, if I log in a root I can launch them.

VGZ... being brought up on the friendly Macintosh GUI I have no idea how to use \'Terminal\'. Could you (or someone) explain how I go about giving the apps execute permissions? I presume it means typing \'chmod\' - something, but I don\'t want to type in the wrong thing and screw the computer up even more.

Also, does anyone know if there is a good web site out there that educates us Mac users as to why we would want to use Terminal, and the commands you can use to do things in it?
Tommorrow i\'ll try to setup permissions... Problem is that it doesn\'t work on newly installed software...

jerome, there are utilities that will help in this issue. try the local browser on the excellent RBrowser or xFiles, just look for an util before delving into CLIs...

I tried the xFiles program and it showed the all the parmissions were turned on for the unlaunchable applications. However, it would not let me change any permissions... it said it was unable (was I supposed to login as root?).

I don't know if this is related to running the xFiles program, but when I rebooted the finder would not load properly... as soon as it loaded it would crash and reload very quickly as if stuck in a loop. So I booted into OS9 and dumped the OSX folders in the trash and reinstalled from the CD.

Now when I boot up I get the login screen, but my old login name and password wont work, so I am unable to login to the computer. I've reinstalled again, but I still get the same problem. I did not choose to initialise the hard disk when I reinstalled because I have other data on the disk I need to keep... is a clean reinstall the only way round this?