Carbon apps suddenly stopped working

Recently, most of my Carbon apps refuse to run. After launching an app, the task bar begins to "make room" for the new icon, then suddenly shrinks back to it's orginal size... the program never runs. :(

Also, dragging a file to the trash results in no action (the file stays put). If I attempt to delete a file using [Command]-[Delete], I am notified that it must be deleted right away.

Anyone else experience these problems?
I had this same problem with classic apps -- when the TruBluEnvironment (what's behind goes down, I see all the dock strangeness that you describe. But never have I seen this with native carbon apps... Nor have I heard of the trash problems you report.
Have you reported this to Apple?

Do these problems go away with a logout and login? Or with a stern restarting?
If not, maybe somehow the carbon frameworks or "LaunchCFMApp," the BSD application that launches carbon apps, got messed up? This should not happen unless the system itself stomped on the files, because user programs shouldn't have the power to do that. If that's the case, a reinstall may be necessary.

Things to try:
1) Open the "Console" application in the Utilities folder (or is it Grab Bag?). Then try to open a carbon app. Look for any messages that pop up in the console while the app tries and fails to start...
A console error message might tell you where the problem is.

2) Open the "process viewer" application. If you can sort by run time, do that, so new apps coms up on top. Otherwise sort by name and scroll to where the "L's" should be. Now try to open a carbon app. Does the name "LaunchCFMApp" show up in the process list at all during the procedure?
I don't know how much knowing if "LaunchCFMApp" starts up would tell us, but it might be a lead, and it might help Apple sort out the problem...


[Edited by zpincus on 12-20-2000 at 01:23 AM]
Well, I managed to fix the problem (indicated above) with my trash. It turns out that the owner of my current user directory got changed to root. I just chmod'ed it back to my regular user name.

Still no results, with the Carbon problem, however.

I used the command "tail -f /var/log/messages" to check out for any errors associated with the failed launch of Carbon apps, but nothing happened. :(
At least on my machine, there is no /var/log/messages file.
Instead, I have /var/log/system.log (and a lot of others, but I think the system.log file is what's important.) Check in there for the messages. (Is carbon? If it does start up, just try checking with that... though the "tail -f" trick is pretty cool -- thanks for bringing that to my attention!)

Clearly all your carbon apps can't be farked, because now that you've solved the trash problem, seems to work, right? And that's pretty much carbon -- but it somehow doesn't rely on LaunchCFMApp to start up. Thus leading me to believe that that may be the problem...

What's the file size of
/System/Library/Frameworks/CarbonCore.framework/Versions/A/Support/LaunchCFMApp ?
Also, try running ps -aux | grep LaunchCFMApp from the terminal a couple of times while a carbon app attempts to start, to see if that even gets executed.

Good luck,
Sorry, I did actually mean /var/log/system.log

I was thinking of my Linux machine. :)

BTW - Thanks for the top -x. I've been looking for the command in BSD that displayed all the processes (it's ps -A in Linux). I read the man so many times and I still managed to miss it.