Carbon Crash



Four days ago I started getting an error whenever I tried to open a bunch of applications (such as Windows Media Player, iPod Updater, Final Cut Pro, etc...). The apps would simply quit, leaving me with an Application Launch Failure box saying something like:

\"The application \"Windows Media Player\" could not be launched because of a shared library error: \'=<WindowsMediaPlayer><CarbonLib><CFMPriv_NavigationServices><>\'

I did a basic google search and found that the problem is in a (corrupt?) Carbon module responsible for file management and navigation (open and save system boxes, I believe). I believe thie error wasn\'t a direct consequence of anything that I installed or updated, as it wasn\'t preceded by any any new installation or update. Would anyone be able to help me solve this problem without completely wiping out my current instalation of Tiger? I\'ve already tried to \"Archive and Reinstall\" Tiger, but that didn\'t work. Isn\'t there a way to copy the Navigation Services files over my corrupt ones? If so, where can I get these files?
Thanks in advance,