Card to add PC laptop to Airport network?


Colonel Panic
I'd appreciate any help anyone can offer here:

I have a new Mac G4 867Mhz, and my wife has a Pentium III HP laptop. Both are connected - with hardwire, at the moment - to a Mediaone/AT&T cable modem via an 8 port 10/100BT hub. Both work great.

However: my wife has recently developed health problems that keep her at home. She is now doing her work from home, and so must spend many hours each day at her computer desk at home, exchanging email with her co-workers. It would be a great benefit her if her laptop could access the cable modem from anywhere in the house.

Now; my father has an Airport base that he cannot use - his office is built with metal studs that badly disrupt the signal. He can't use the base unless he's in the same room with it, which totally defeats the purpose.

So my question is: can anyone recommend an EXACT manufacurer/model# of an 802.11 card - and software strategy that would allow my wife's Wintel laptop to access the cable modem wirelessly via the Airport base?



Do not read this sign.
Oh. Exact. Sorry. But I know I've seen some articles online somewhere where people have reported using a Cisco model with an Airport base without problems.

If you do find out, or just buy one and try one, let us know if it works.

I think Best Buy has a generous return policy if the card doesn't work.



Colonel Panic
:D I got that sucker to work! WHOO-HOO!!! :D :D

Here’s what I did.

First the hardware:
Powermac G4 Tower – (NO airport card)
HP Pavilion N5190 Wintel laptop
Netgear MA401 802.11b card (only PCMCIA 802.11 card I could find locally)
ToshibaPCX1100 cable modem, with Mediaone (AT&T Broadband) internet service
D-Link DSH5 10/100BT Ethernet hub
Apple Airport base

I connected the Airport base to the Ethernet hub, then ran the Apple Aiport Admin software on the G4. The software quickly identified the Airport, but when I clicked “Configure”, I got an error telling me that I was not on the same subnet as the Airport, and so could not administer it.

I resolved this – oddly enough – by disconnecting the Cable Modem from the hub. I think I also rebooted the G4. Mediaone requires that all MAC addresses be ‘registered’ with them, and so because the Airport’s MAC had not registered, the DHCP server would not assign the Airport a ‘real’ TCP/IP address.

After disconnecting the cable modem, I was able to administer the Airport.

I did the following:

Under the “Airport” tab, I put in a more succinct Network name “BrianNet” . I left the other settings the same. (Although I did change the admin password.)

Under the “Internet” tab, I set “Connect using: Ethernet” and “Configure TCP/IP: Using DHCP”. I left “DHCP Client ID” blank, but some ISPs may require one.

Under “Network” I checked “Distribute IP addresses”, and selected “Share a single IP address (using DHCP & NAT)”, and left “Ethernet client computers also share….” unchecked.

Under “Access Control”, I made sure that the list was empty.

Then I clicked “Update”.

I exited the Airport Admin application, rebooted, and contacted Mediaone to add the Airport’s MAC address.

I had to power off/on the modem, G4 and Airport, leaving each off for several minutes.

Then I installed the Netgear card into the laptop. I powered on the laptop, and it detected the card and asked for the driver CD. I put the CD in, and the drivers were installed.

I also installed the Netgear card configuration utility.

Following the advice on this page:

I opened the Properties screen on Network Neighborhood.

I then got properties on the “TCP/IP -> Netgear MA104” entry.

Then I went to: “IP Address: Select Obtain an IP address automatically”

Then to: “Gateway: Enter the IP of your Airport into the Gateway”

But I DID NOT bother with “DNS: Enter the IP of your ISP's DNS servers into DNS, and make sure DNS is Enabled”. The setup instructions for Mediaone have never included manually entering a DNS, so I assumed (correctly) that it could be skipped.

Then, just for good measure, I deleted the “TCP/IP -> Built In Ethernet” line, to force the laptop to use the wireless card.

I exited Properties, and restarted as directed.

Then I: “Fire[d] up [my] wireless card's configuration software [and] Configure[d] [my] Wireless card on [my] laptop to Infrastructure mode and enter[ed] [my] ESSID exactly the same as did in [Airport Admin, under Network Name (BrianNet)]”

In the Netgear’s software, the “ESSID” was called simply “SSID”.

It worked like a charm. My wife’s laptop can now access the internet from anywhere in my house!!!

I’m so happy….