(Catalina issue) Macbook Pro built-in keyboard and trackpad are unresponsive

Half Baked

Registered
I am writing this post about an issue I've been having with my 2019 Macbook Pro running Catalina 10.15.5.

Often, when I open my laptop, the built-in keyboard and trackpad are unresponsive. If I don't close the laptop, a window will pop up after 15-30 seconds that says "Bluetooth keyboard setup. There isn't a keyboard connected."

This problem was frequently happening every single day. I tried the following things to no avail:
1. Resetting the SMC
2. Resetting the NVRAM
3. Rebooting in safe
4. Deleting potential problematic plist files as suggested in this article.

So I factory reset my Mac, reinstalled MacOS, then restored a backup from Time Machine.

Factory resetting has been the only thing that has had any positive impact on this issue. I encounter the problem much less often, but it isn’t gone completely. The keyboard and mouse are still occasionally unresponsive when I open my laptop, particularly if it is plugged in (though it happens when not plugged in too).

One thing to note is that the fingerprint reader/power button still works even if the rest of the keys on the keyboard don't—I can triple-click the power button to open the accessibility options, though I can’t select anything because this doesn’t cause the keyboard and trackpad to start working.

I'm certain this is a software issue. This problem started when I updated to one of the supplemental Catalina updates around 10.15.13/14 (I’ve learned my lesson about updating—if it ain’t broke, don’t fix it). My Mac has had no spills, drops, or other physical damage.

Additionally, waiting usually solves the problem. Meaning, when I open the lid and the keyboard and trackpad are unresponsive, if I wait a few seconds (or sometimes it takes up to a minute or two), then everything works and is responsive. Also, I am not the only one with this problem! I’ve come across several posts of people with the exact same problem (on the 16 inch Macbook Pro).

A solution would be much appreciated!
 

SGilbert

Registered
If you have no bluetooth devices, have you tried turning off Bluetooth in System Preferences? Go to advanced there, also, and uncheck all. Restart.
 
Top