Cause Mission Control To Not Switch Between Workspaces?


I am running Yosemite. When I run a program from within another program, e.g. a java swing application, it always appears on the same workspace, which is usually not the workspace I am working in. Is there a way to get mission control to not make windows appear on a different workspace then the workspace containing the program that I have just typed into?

Also, generally, I would like to never have mission control switch the workspace that I am looking at. This might only happen when I have a window displaying full screen. But, I will open a program and it switches the workspace and displays the workspace that the application I switched to was on. This is really annoying.

I think I have tried all options, but maybe not. I have "when switching to an application, switch to a.." unchecked. Is there anything else I can do?
I haven't yet tried assigning every program to the window it is on when it first starts yet. So, I will try that though it is a pretty laborious solution. But, I thought I would describe a situation that make the behavior particularly problematic, in case it is relevant to someone. I have a program that prompts the user for a password. The way this works now, the prompt pops up on the first display rather than the one I am interacting with. Several times I have spent several minutes boggling over what could be wrong with the program until I notice that there is a little window on a different desktop prompting for a password. This is a disaster, more or less, since I need to give this program to other people.