CD drawer just opens and won't close


This just started happening. The CD drawer just opens and I can't close it. If I try to close it after 30 seconds it just pops back open. If I insert a CD, it will not read it either and will eject it.

I have tried changing the keyboard, unplugging all external devices, repairing permissions, rebooting, checked the start-up disk.

Anyone know what is going on with this??? Thanks.

PS: running OS 10.3.9 on a 867Mhz PowerPC G4
thanks. no luck yet. tried to reset the PMU, log in as a different user, etc. but to no avail. I think I need to pull the drive out and try another one.
I disconnected the data cable from the CD-Rom Drive and rebooted. Again, the drawer opened on its own before I even reached the OS X user login window. Is this a sure sign that the drive is shot?
I'm wondering if maybe it might need some cleaning. I didn't try that with my CD-ROM when it was doing that, but it might do the trick. There are some CD-ROm cleaning kits that help clean the lens if it's dirty. If that doesn't do it, I would consider it shot.

How new is the CD-ROM?