CD-ROM stops working after 10.0.1 update


Do not read this sign.
After installing the 10.0.1 update (actually it was the 1.3.1 software updater update that killed it), I can no longer mount any CD-ROMS--HFS, ISO, ISO/JOLIET, not even the Mac OS X CD--on my PowerBook G4.

Has anyone else experienced this and, of particular interest, fixed it?

Still no luck.

Does anyone know if support for CD-ROM formats are "pluggable"? Maybe some /etc file got corrupted, ya know?

From what I can tell (no manpage on it) the process autodiskmount seems to be the mounter of CD's and such. First check to make sure it's running, and check /var/log/system.log to see if it is complaining about anything.
Good call. I'll check it. 'Course it <em>does</em> recognize that I put a disc in. It just asks me to initiliaze it! Wouldn't that be nice: a burner in the powerbook.

i posted exactly the same problem in the thread "Big Problem with CD and .img/.dmg". I heard many people have this problem!
Could anyone with a bit of influence please contact apple?
Anyone ever tried to mount the CD manually via the mount command? Any success?
No luck yet. I found some kernel extensions related to storage that were updated with 4L13. I'm going to try replacing them with the ones on the OS X cd. Wish me luck.

Replacing some of the kernel extensions didn't help, so I put them back.


I have heard this problem in too many forums now (and I am suffering under it myself on two G4s). Could anyone who speaks english as his native language (so not me) formulate a mail to apple under which we - who suffer under the problem - can write our names so they see that this problem is damn important?
Most people - me also - have the same problem when mounting .img (allthough this works for me at home, at work it's the same fault) which makes it impossible to install any applications delivered in that format.

If anyone writes such a mail, please include this:
Ulrik Witschass
System: MacOS X 10.0.1 German release
Machine 1:
PowerMac G4 450 Sawtooth
512 MB Ram
DVD Drive
Machine 2:
PowerMac G4 Dual 450 Sawtooth
256 MB Ram
DVD Drive
Yeah, frustrating. I'm reinstalling OS X. I'll then apply the update before I do anything else, to make sure I can isolate the problem.

Fortunately I don't do anything mission critical on OS X yet, so it's merely an inconvenience to re-install, but that's hardly a legitimate solution.

I have posted my console log showing the failure to install 3 files. See the thread "Disk image mount problem".
ok..this isn't help for anyone at all... sorry...

anyway, I have an external firewire CDRW... which works just fine...

the builtin DVD drive worked only the first time the system booted after update... it opened and closed just fine... but I can open this drive only at startup now... and if I put a disc in, the only way I can take it out is by rebooting and pressing the eject button then... rather dumb...

I hear 10.1 is coming soon.... I just hope this gets fixed...