CGI & PERL on OS X Server 10.1... HELP ME!!!


I've just installed OS X Server 10.1 and it's all running fine... all excluding PERL!!!
That's a real big problem cause i use intensively Perl...
I get an error of "Internal Server Error" and i cannot do anything.
The scirpt is correct
The path to Perl is correct
The CGI-permission are activated
The permission are right

Into the ErrorLog i see it's a "premature end of file" error... but i dunno what i have to do to run PERL scrips with OS X!


Please, list your path to perl, url of the script, and the script you are using. Without being able to see this info, anyone will just be shooting in the dark.
By the way, I have noticed that using anything other than Get Info (the app not the function) permissions are often not set properly. It doesn't make sense, I know but it has been the case for me before. Anyway, try it and post the details and we'll see what we can divulge.
These are the specific you requested...

the Perl path is the same: /usr/bin/perl
the Path of the script is: /Web/hermes/bin/admin.cgi
I'm using a script written by me in Perl... i've tried to change the extension of te file between .cgi and .pl, but no results. I've also tried using the basic Perl script "Hello World", but not working... that's a problem.

My ErrorLog says it cannot find a file (wich file???) and that it reached a premature end of the script.
I dunno...
Which directory are you running the site from?
I run all mine from:

Which makes the path to a script:

It looks as though you are running your script from your:

I have never successfully run a script from here so I'm sorry but i couldn't advise you properly if this is the case. IF you are in-fact running from the WebServer directory, try the path I mentioned above. Let me know what turns up.
Ok... so effectively i run my website from /root/Web
but now i've changed it to /Library/WebServer so the real path of my website now is


I've tried both to put the script "" into a directory into hermes...


and both into the "CGI-Executables" folder


but still not working!!!!
I cant imagine this being the problem but just to make sure all options are to be exhausted, try dropping the script just into the CGI-Executables folder with no other directory created inside it.
BTW, did you do a complete clean install of 10.1 or just upgrade?
I've a question...

My "server admin" show that the mod_perl is not running... can be the problem?
An i have also viewed that the Apache here in MacOS X is not installed as in a conventional UNIX platform... cause if i wanna install mod_perl i have to specify the apache/src directory (usually located on the root in UNIX) but here in X i cannot find it.

And finally... WHY I CANNOT VIEW ALL THE FILES AND FOLDER ON THIS SYSTEM!!!!!!! I cannot view the folders usr, bin, sbin.... ahhh... that's no possible for a SysAdmin to work this way... only with the terminal... there is a method to view all the files in Aqua???

When you say that "server admin" says the mod_perl is not running, are you saying you are running OSX Server? Server comes with the Server Admin program but OSX client does not. But yes, that points to a problem.

If you wish to view the invisible files you should download and install Tinker Tool 2.0 preview which I use with no problems. It has been put from final to beta because the new beta is the first release for 10.1 but it is totally stable.It will allow you to see all files. If you need to uncomment the perl line in httpd.conf you need to log in as root and open it via:

Get Tinker Tool from
Just search for tinker tool.