CID font problems in XFree86 4.5


I'm wondering if any of you have been using Xfree86 4.5 or the latest Xorg X11 platforms lately. I recently decided to change from Apple's X11 to one of these and have been having font errors appearing in the start up ever since. Firstly I've tried a couple of things here.
I installed Xorg from the CVS (working out CVS - never heard of it before - was a nightmare in itself). Which plain simply wouldn't work at all, with a lot of errors including ths one which I've been having with everything else ever since; :mad:

Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
Fontconfig error: Cannot load default config file
Warning: Cannot convert string "" to type XftFont

There was also a USA.keymapping error which I managed to solve. If anyone else has the key mapping error, I found a reference to it in the darwinports forums somewhere. They had a downloadable file (there were instructions in the forum on what to do with it) that you bury somewhere deep with in the your system directorys and it solves the problem.

As it was, I tried installing Xorg with Fink with no luck, then decided that maybe that version of Xorg was going to work, so I've now installed Xfree86 4.5 using darwin ports. The above font error still appears, but it will start with startx at the terminal although the clickable Xdarwin icon doesn't start after choosing you display (full screen or rootless).

I've found the font config file in
that is read by Xfs (the X font server I assume)
(although I still don't quite understand where Darwinports or Fink actually put stuff in general, and where config files are located).

Incidentally, how do we check if a service is running, ie on linux you'd type Xfs status, but on Mac OS X the status, start, restart, stop daemon calls don't seem to be available?

I've been searching all over the net for a solution and it seems that people on all platforms (i.e. Red Hat, Debian, Suse etc..) are having the same or similar font problems. They also have the option of using one of the font configuration utilities that we don't (such as XftConfig etc..).

At the moment, I think the problem may be that I don't actually have any of the CID fonts installed, well not in the /usr/X11R6/lib/X11/fonts/CID/ directory anyway. All it contains are fonts.dir and fonts.scale, which are both empty text files. The other font directorys (i.e. Speedo for instance) contain *.spd type font files (or fonts suitable for that direcotry), and the fonts.dir and fonts.scale files actually reference the *.spd files.
I've found that the Adobe reader application contains some CID fonts and I was wondering if it may be possible to use these? I have read somewhere on the net that for X11 to use some of the Mac fonts, they sometimes need converting. At the moment I'm still trying to search through the Xfree86 sites, to see if there is maybe * file out there that DarwinPort may have missed, which hopefully may contain the CID fonts, and then I'll need to figure out how to install them. Has anyone got any clues to this?

By the way, do any of the windows managers allow cut and paste between Xwindows and OS X without having to install extra clipboard type applications? I was thinking Orobosx, but I haven't fully investigated it.

By the way I'm using Panther 10.3.8, I can't upgrade any more because there is no more support for my Digi sound card (which cost over half the price of the Mac, so I'm not about to throw it away)