Citrix Metaframe Access Issues


I have been trying to access a corporate Citrix MetaFrame Server with no luck. I have tried using Safari, Firefox, and Internet Explorer.

With Safari, I get an error with "Error opening ICA file" as the description in the "Client for Java Connection Center" window. There is no response from Safari and I have to force quit Safari.

With Firefox, I get and error with the following description:

SSL Error 0: You have not chosen to trust "/C=US/ST=/L=/O=Equifax/
OU=Equifax Secure Certificate Authority/CN=", the issuer of the
server's security certificate.
Error number: 183

I get the same error with Internet Explorer.

I am running the Citrix ICA client for Mac OS X version 7.00.405

Any help would be greatly apprecitated.

TMAN2005 said:
I finally figured it out.
The solution:
I found the appropriate certificate on and copied it into the keystore directory in the Citrix client directory structure.
I have the exact same problem, but haven't been able to find the equifax certificate at geotrust. Could you be more specific on where to get it?

I'm also having issues with the Citrix ICA client. The problem I'm having is that the LAUNCH.ASP file tries to open with Photoshop or Dreamweaver. I can't get it open with the Citrix client. How can I change the file association so ASP files open the Citrix?