Classic Applications Are Documents After Tar Restore ??

CowboyHenk

Registered
Hi,

I have restored classic applications using tar -xvz on a new Tiger system (10.4). The applications and all related documents have an icon similar to a terminal screen (I suppose this is the default icon for "unknown" documents). If I try to start them my Mac can't find the application for the document (regardless whether Classic is running or not). Even when I boot with a System 9.2, the programs do not run (and show up with a PC/DOS icon).

The archives were created after a harddisk crash on a 10.2, when I still had some functionality, with the corresponding tar command. I have backuped and restored the Users folder successfully the same way. It seems there is no problem with the files itself (the HD problems were all in the system and could be isolated).

How do I make my files applications again (that run in Classic and start it up when necessary) ?

Thanks,

Henk


Don't bother trying to solve this one : I tried to untar a Mac archive onto a DOS volume (on a newly purchased firewire disk, that was preformatted DOS).

I didn't realize it was a DOS volume until I found out it behave strange on "normal" disk operations like copying files using OS X. E.G. it refused files with a ? in their name. The I realized my mistake, reformatted the disk and all problems are solved !

Greetings, Henk
 
Top