Classic doesn't finish 'booting' in os X

kilowatt

mach-o mach-o man
Allright, I've read the kbase articles, upgraded everything, and searched this site several times, and I can't find an answer or an identical problem.
Here's the story:
I've got a 40 gig ide hard disk. Here's the partition map: 5gig os x hfs+, 1 gig os9 hfs+, rest is a big hfs+ partition. I'm running mac os x retail (I think its 10.0.1, updated), and Mac os 9.1 (with the startup disk control panel update). I've got 128megs of ram on a supported computer (beige power mac g3, 266mhz rev. a). When I go to the system preferences and get into the classis panel, I can get it to go into classic, but it will not finish 'booting' classic. With the extensions on, classic starts up in a 800x600 window (I think) and loads all my extensions. It then gets to the point where the osx status bar thing that is above the os9 window is about 99.999% finished. The menus haven't poped up, nor have any of the typical os9 desktop icons (hard disks, trash, etc). I just get a grey menu bar, and a desk top background. I've let it sit for hours, and thats all I get. Forc-quitting classic is the only way out. Now, starting without extensions is a bit different. The computer gets to that 99.999% spot, and stays there a minute or so, and then the classic window disapears. Classic does not appear in the dock. But, pressing opt-apple-esc, or performing 'ps aux' in the shell reveals that it is still running. Once agian, forc-quitting is the only way out. Any ideas?

thanks!
 

twister

Howdy
first off if classic is running it wont show in the dock. It just does while its starting.

my only ideas are probably things you have already tried. Zap the Pram, rebuild the os 9.1 harddrive through os X, and run disk first aid. Does os 9.1 work fine if your starting just 9.1 and not X?

Maybe you need to re-install X but i hope it doesnt come to that.

Twister
 

ElGreco

Registered
The culprit is SLM PPC. Try deselecting it (starting from system extensions/classic -extension manager on) in the extension manager on boot-up. If it works you are one of the unlucky users that, for whatever reasons, have a bulky Open Transport in Classic. I belong to this group too.

Deselecting SLM PPC will cause OT not to function. Though Classic won't be of great use. There are many ideas, tipps, tricks to be able to boot with SLM PPC. Try some:

- Move the OS9 Preferences out of their folder. If you may starup with SLM on, lucky you. Just put the preferences back in bit by bit to see which one caused the stall. (Note: Restarting in OSX is okay, so you won't have to skip systems all the time.)
- Trash hosts file.
- Trash OS9 appearance themes (except platinum) AND sounds (all of them).
- In the OSX system preferences panel/network/TCPIP clear the field search domains.

For me the themes trash workaround ended up as a success. Sounds ridiculous. The problem is somewhere in OT, so any strange change may have the wanted effect. Simple as that. Only sad thing is that Apple does not correspond to any of these topics. And believe me, many users are suffering from this problem. Even though Classic most often works now for me, it is very, very unstable and likely to crash. With SLM PPC off it is stable but won't let me connect to a network and not even print. Eventually, this does not sound very promising to me.

I cannot await abandoning Classic. I am desperately waiting for a native HP OfficeJet G85 driver. Anyone know if they are in beta testing already - or even better: Can anyone mail me a working beta for this printer in OSX???

Later,
Roman
 
Top