Classic makes my G4 crash after having installed Tiger


Hi there

I've very recently upgraded my g4 from Panther to Tiger.

I can start the g4 trouble-free from OS9.

Classic was working perfectly before the upgrade, but now this happens:
I start it, the smiley face of the welcome to OS window comes up, I can see all the extensions loading up at the bottom, while the blue bar is going further and further.
Then, just when it should be about to have finished loading up, the computer freezes, while a brownish rectangual square is the middle of the screen with lots of letters etc, saying to hold on the power switch for few seconds in order to restart.

Does anyone have any suggestion on what can I do?

Thank you in advance


iMac Dual 2.0 17'
Are the two OSs on the same drive, or separate drives? When you installed Tiger, are you sure you included OS9 drivers as an option to the OSX part of the drive?


the 2 OSs are on the same drive.
During installation i don't know if I've included OS9 drivers "as an option to the OSX part of the drive" (i don't know what does this mean...i've just updated the system following the onscreen instructions).


The Late: SuperMacMod
If you just upgraded, no need to install drivers for OS 9.

In the Classic PreferencePane turn off Extensions and see if it will start.

Check Software Update to see if there are any updates for Classic.


Ok, Done the Check Softwafe Update: I've just updated the System to 10.4.2.

I've started up Classic with Extensions off....yes, it does start up.
An error comes up saying that "Launch of hp inkjet engine failed - the application hp inkjet engine could not opened because InterfaceLib-- GetComponentResourse could not be found".

What should I do now?
How can I identify which one (if one) is the extension that makes me crash?
Could it have to do with the error message that comes up (it has never appeared before)?
I know, if I was starting from OS9, using the Control Panel, I should try starting up with groups of extensions, till I find and isolate the one/ones which I have to unistall.
But starting from OS9 it's fine. How can I do this from OSX?


Ok, I found the solution :)

As suggested by bobw, it was true it had to do with the HP software driver.
Here, as follows, what I have done:

First I tried unistalling the HP deskject 3550 driver using the CD that came with the printer. This installer/unistaller in here contains both the driver for OSX and the one for Classic. During unistalling, it launched Classic (i don't know why, maybe to unistall something from there?), which it was crashing - as when I was trying to launch Classic anyway.
I tried several times, and it kept happening always the same, without been able to finish the unistall properly.
I tried as well restarting the mac from OS9 and unistalling the driver fro the same CD.
Still crashing.
Finally, I've downloaded from
the printer driver and then:
I've first used teh unistall (which seemed to have been able to remove some but not all the files, because they'd been installed with a different installer.
Then, I've installed the driver.

Now Classic works.

Thank you to everyone fro your help!




oh no....
it did work (i started Classic twice before crashing again), but now it crashes again...with the difference that, if I start Classic with extensions off, the Engine error that seemed related to the HP deskjet printer message doesn't come up anymore......