Classic not seeing HD

anerki

Registered
Why would a Mac OS 9.2.1 not see a Mac OS Extended formatted HD (with the Classic drivers installed) in a Powermac MDD and without problems in a Powermac AGP Graphics?

Edit: It boots perfectly, although a touch slow, from the Mac OS 9.2.1 CD. It just doesn't recognize any of the HDs. Is this also, because it's not Mac OS 9.2.2 (which is supposedly the Classic OS of choice I need as listed here.

I don't have the official CDs that came with the machine (bought it second hand).
 

Cheryl

Rosie Moderator
Staff member
Mod
Check the CD that you are trying to use. If it has a specific model on it, you will not be able to use it on a different model Mac.

If it is a full install retail CD, use Disk First Aid in the Utilities folder to check over the drive.

If it is an empty drive, use Drive Set up to format the drive (again).
 

anerki

Registered
It's a full retail CD of Mac OS 9.2.1. Neither Disk First Aid or Drive Set up or anything works. When booted in Mac OS 9.2.1, it doesn't physically recognize there is _anything_ in the slots. To reboot in X I have to open the machine, disconnect the ATA/33 cable of the CD drive so it'll just stop rebooting in Mac OS 9 ... Then set the Start up disk to the HD again with X on it, shut down and enable the CD player again ...
 

Cheryl

Rosie Moderator
Staff member
Mod
The drive has OS X on it. When you did the format - before you installed OS X, did you select Mac OS Extended format and install the OS 9 drivers?

If you did not install OS 9 drivers (which could be the reason 9.2.1 does not see the drive), you will not be able to install OS 9 without wiping the drive, reformatting and get those OS 9 drivers installed.
 

anerki

Registered
There are two drives in the machine. The standard 120Gb one that came with the machine has X on it and the 9 drivers not installed. And the 40g one from my former Powermac, which is completely empty, been formatted over and over, and every time with the drivers for Mac OS 9 installed.

Booting in classic from CD sees neither of these drives. Nor the one with the Classic drivers, not the one without the Classic drivers.
 

TommyWillB

Registered
When you put the 40GB drive in the machine did you correctly reset it as the ATA "slave" vs. "master"?
 

anerki

Registered
That's worth trying again. I tried it with another HD that eventually ended up not working alltogether.

The X drive is the "Master" now and the 9 drive is "Slave" although they should both be set to Cable Select I used Master and Slave ... Because, basically it was the first I tried after a frustrated 40-ish tries with another HD. I'll try setting the 40 Gb (Classic) HD as Master, and the big X drive as Slave. And then again with "Cable Select" as I'm supposed to use ...
 
Top