Client Login Window

oldgit

Registered
Sorry, but this is a question with a very simple answer - but I'm lost!!!

I've set up 10.3.9 sevrver on a G4 desktop and everything works ok - add users, log them in, open apps etc. Unfortunately my clients lab doesn't appear to recognise the network for login purposes.
I can access the server through DNS, and my clients appear in the DHCP list in Server Admin. But, the clients can't see the login - ie they don't have the 'Other...' box enabled in the login window and, even if I force this by making the login window a 'Name and Password' type, the users aren't recognised.

I'm pretty sure it's a Directory Access issue, but everything there appears OK. It's probably something very basic - so here's the chance to make me look foolish.

Thanks

BTW I'm using both Panther and Tiger clients.
 

Kees Buijs

Registered
oldgit said:
I'm pretty sure it's a Directory Access issue, but everything there appears OK. It's probably something very basic - so here's the chance to make me look foolish.

Thanks

BTW I'm using both Panther and Tiger clients.
Is thi problem starting after installation of the 10.3.9 update ? If so, check out below:

If you look back in the history of the site you will find that i reported the same problem after installation of 10.3.9 update on a perfect running 10.3.8.

After calling to apple tech (and telling them i expect support although i would not get it because i bought to long ago) they helped me and got it more or less running.

The main problem is a change in the LDAP record structure, which should be fixed (after a very long processing time).

Apple made a document on this: 301384 on the Apple site “www.apple.com/support”.


I ended up re-installing 10.3.4 and upgrading to 10.3.9 (it is oke as long as you do it before creating any users using LDAP).

Before re-installation you should backup the map 'var/imap/spool'. This map contains you mails. You can rebuild the required databases using the following document from apple: 107996 on the Apple site “www.apple.com/support”.

I modified it slighty so it works a little better:

su
mv /var/imap /var/imap.old
mkdir /var/imap
/usr/bin/cyrus/tools/mkimap
chown -R cyrus:mail /var/imap
chown -R cyrus:mail /var/spool/imap
sudo -u cyrus /usr/bin/cyrus/bin/reconstruct -i
sudo -u cyrus /usr/bin/cyrus/bin/cyrus-quota -f

(if not already logged on as superuser (su), than paste the script twice in the terminal).


After a proper installation of 10.3.9 i was pleased with it, but not with the way apple made me use it.


Gooed luck, Kees
 

Pardus

Lurks: 15,289
i had that problem when I moved around some imace from one lab to another. they are just on 9.2 but the problem was that the client version of macintosh manager was 1.4 and on the other server it needed to be 1.3 and so the clients password was always rejected. uninstalling macmanager 1.4 and reinstalling 1.3 worked. With 10.3.9 maybe you need to check what version of directory access you are using on client machine or another software update.
 

oldgit

Registered
Thanks - have re-installed back to 10.3.2 on server and am able to get login. However, still not perfect as I cannot create usable 'Home' folder. I keep getting Unable to Login messages because 'The home folder for the user account is located on an AFP or SMB server.'

Probably something very simple and obvious - but it's escaping me at the moment.
 

Millie

Registered
This is my second time asking a question here and I am happy to say the first time was a great experience. Anyway my idea was to see if anyone else was asking a similar question. While I can't always tell if the questions are similar I am going to take a risk and see if my question is related to this thread.

I have set up OS X Tiger on a G4 desktop. The lab computers are older iMacs but I have coaxed them to 10.3.9 - they log in happily to the student folders on the server.

I decided that since some of the older machines are really short HD memory etc. that I would try upgrading only to OS 10.2.8 instead of 10.3.9 - since it seems to use a lot less space. Anyway - following the directions for configuring the client machines that I have for the 10.3.9 machines - does not seem to work for the 10.2.8 machines.

This is the message I am getting from the computers that have OX 10.2.8 on them (instead of 10.3.9) when i try to log on

The "home" folder for user "XXXXXX" cannot be found in the usual place.

The "home" or "users" folder may have been moved or deleted. If "home" is located on the network, the server may be temporarily unavailable. If you continue to have problems see your system administrator. (that would be me :)


I configured them them same way that I have been configuring the others (though it does not look exactly the same in 10.2 as it does in 10.3) I can find all the pieces that we used before. The only common denominator that I can discern is that it is not working for the OX 10.2 computers. The login works fine on the OS 10.3.9 computers but when I try to login with one of the students' names on the 10.2 machines, the above message appears.

Any ideas?

Thanks - amy
 
Top