Cloning OSX Machines

Ghoser777

Registered
Okay, listen to this little problem. My school (and I'm guessinf pretty much every school) clones their machines off a base machine. So, I'm trying to get the hang of it with OSX PB before the real thing comes up and u know what hits the fan. So I booted into OS9 and used regedit to reveal all those nifty files. But tryint to copy the files directly to another location becamse very difficult - everything with a "#" character gave me this crazy undefined 1410 error. But, I would not be defeated easily. I simply tried stuffing every file, whi worked except for the HFS Private Data, but I think that info is generated automatically (although I could easily be wrong about that). But here's my new problem: after wipping a mac and copying/unstuffing all the relevant files over, the machine starts to boot into OSX, but then suddenly jumps to Darwin and complains about the etc directory...

And here's what I've discovered: the etc, core, tmp, and var directories are really symbolic links (essentially aliases) to the real diectories in private (which is a hidden directory). This really shouldn't be aproblem, except for that the reason it jumps to Darwin is that the symbolic link files, for whatever reason, are no longer symbolic link files! This is greatly disheartening. Of course, you're probably wondering, "Why not just make new symbolic link files by typing ln -s private/etc/ etc ?" Ahh, but if only it were that simple. It seems that in this demented state of Darwin, all files and directories are read-only... which means I can only alter data via booting from an OS9 CD, from which I know of no way to successfully make symbolic link files (I tried res edit, but no luck). So, anyone out there got any suggestions?

Thanks a lot!
F-bacher

P.S. I'm going to try stuffing the entire OSX partition tomorrow and see if that preserves the symbolic link files, but we'll have to wait and see...
 

The DJ

Registered
Try to gnutar the partition from another OSX machine.
I believe it has some nifty features to preserve a lot of unix info. I suggest you read the gnutar man page.

DJ
 
You said something about the links being read only.... Well, doesnt root have read/write access to every file/folder? Or maby this is not your problem... You could hold s down durring start up which would load up a command prompt (which i only used to check for errors using "fsck." Or maby this doesnt work eather..... You could try making the files read/write before you compress them. And here's something eles to try..... use a unix compression format instead of pre mac os x (i.e. .sit)
Good Luck!
 

Ghoser777

Registered
My all powerful boss wipped out his admin book and used: "/sbin/mount -o rw /" to get write access. Now, i have the fun job of fixing not only the first 4 broken symbolic link files, but also the 446 other symboli clink files! (I searched by type under OS9). This is going to be a pain in the butt.

Oh, about the root thang - the problem was that since the symbolic links were all messed up, I couldn't even su to root. All that info was in private/etc.

Another thing - instead of stuffing it, this time I tried just copying the files over appletalk directly, and it workd great! So, that was nice to know. No # problems.

Here's something interesting: all the broken slnk (symbolic link) files share a common property - if you pico them, the directory to whcih they point to is there. So, the new question: is there away to have the borken slnk files be run through pico, have their info saved, then remove the file, and then create a new slnk with the copied directory pointer? Whew. I'm going to be doing some fun research tonight.

Oh, and has anyone ever heard of a program/command called kats? I found a sight about how u can change macos files under unix with it (aka the creator), but I don't know where to find it.

Thanks,
F-bacher
 

The DJ

Registered
Know what, i will ask at our university how they do that with their linux machines. I suppose that will work for you too.

DJ
 

Ghoser777

Registered
Well, I'm really close now. I wrote I nice little perl script (actually some guys I work with who know a heck of a lot mroe perl than me did, but I typed it :)) that would read a file that listed all the symbolic link files, open the broken symbolic link files and copy out the correct directory to point to, delete the broken symbolic link, and create a new, functioning symbolic link. Whew... Well, all seemed okay at first, but it turns out that when copying over all the files, some important things, like perl, had size 0. The original machien I copied off of had a nice sized perl file though. Several other files, like tcsh, were also zeroed. So, I copied over the perl file by itslef, and then the script worked fine and the whole system booted.

So, this seems like a pretty big mess. I'm going to try creating a disk image using the old disk copy (because the osx native one has very limited abilities) and then copy over an entire OSX partition of a dual-partitioned hardrive. We'll c how this works...

F-bacher
 

cabbage

Registered
purchase Dantz Retrospect 5.0
I tried Carbon Copy Cloner but it wouldn't work.

With Retrospect I've successfully cloned OS X from
1. volume to volume on the same hard drive
2. volume to volume on 2 different hard drives
3. volume to a FireWire HD
4. FireWire HD to a volume

I tested out each one for 3 days doing what I normally do and they all worked great.
 

cabbage

Registered
heh...only a year and a half
i was doing a search on a mysql os x server question i had and that popped up!
 
Top