Computer No Longer Recognizes Camera



We have an Olympus 4000C. I've been using it for almost 6 months on this computer (G5). Just the other day it stopped recognizing it when we plug it in as we always did. No logo comes up on the Finder or anywhere. I tried it at Best Buy, both the camera and cord are fine - what am I missing? My daughter often uses the camera, it's possible she turned something off without knowing it. Any ideas?

Thank you,
Have you tried a different USB port on the computer? The one you are using may be damaged.

Also, I don't think it will help, but try formatting the camera. This is usually an option on the camera. Move all your files from the camera to another computer first.
I noticed that my Cannon doesn't mount a drive in finder like my Sony used to, but I can still get stuff off using iPhoto.

Have you tried opening iPhoto and doing a photo import?
Hi Ann,

Have you tried reinstalling the drivers (software) for your Olympus C4000? I have an Olympus D550 and had the same thing happen on my PBookG4. Connected the camera via usb numerous times and wham... all the sudden, the camera wouldn't mount on my desktop. I downloaded and reinstalled new drivers and that did the trick, maybe it will work for you. I looked up the url for you. Just copy and paste into your browser address bar.

Hope this helps!
Carolyn :)