./configure issue with popt for gcompris-6.5.3

2b

Registered
Greetings,

I am a new Mac user, using PowerPc G3, OS X 10.3.9
I'm finding it challanging to install gcompris
(http://gcompris.free.fr/rubrique.php3?id_rubrique=2) that I found on gnu site.

I've attempted to install all the required packages with Fink, and have attempted to compile the packages that were not in fink :(

So here is what I get
./configure for gcompris fails with the following message:
PHP:
checking for poptDupArgv in -lpopt... no
configure: error: You must have popt 1.5 or newer to compile gcompris.
Fink shows that I have popt and popt-shlibs version 1.7-5 installed!
In attempt to workaround this I tried to download and compile popt 1.8-1. Though, I was able to run ./configue on the popt 1.8-1, I am getting the following error when I run make install:
PHP:
.deps/findme.Plo:1: *** multiple target patterns.  Stop.
I appretiate your help.
Thanks
 

spb

Registered
You probably need to pass to the configure script the location of the popt library.

Find the library, probably called libpopt.a or libpopt.dylib, and note the directory it's stored in.

Then when you run ./configure you'll need to pass a flag such as

./configure LDFLAG = "-L/directory/library/is/in/"

It might not be called LDFLAG, but there is some type of compiler flag you need to set. Frequently if you run "./configure --help" the configure program tells you what flags are available to set.

sb
 

2b

Registered
Thanks for the Tip sb. It worked.
 
Top