"Connect to server" problem, error -35

marklamond

Registered
Hi there,

I'm using OS 10.4.1 and when trying to log on to either Windows or Netware servers via AFP i now get the following error message:

"The operation cannot be completed because one or more required items cannot be found (error code -35)"

This problem only occurs under the Administrator account, all others are fine.

I'm struggling to find any information on exactly how the "Connect To Server" feature works and files involved etc, so i tried installing the Microsoft UAM (universal authentication module), and the MS UAM works perfectly, but i still cannot connect to Netware servers, and it hasnt actually solved the root problem anyway. This would prove that there is something wrong with the internal UAM (if thats what it's called).

The only thing i have found so far was that this can be caused by a permissions problem, however after repairing the local drive's permissions it has made no difference.

Does anyone have any ideas?

Many thanks,
 

marklamond

Registered
Managed to fix the problem, trash the "GlobalPreferences.plist" in:

/<username>/Library/Preferences
and
/Library/Preferences

Trashing the /Library/Preferences one fixed the Netware logon problem, but not the Windows one, i then trashed the other one and it fixed that also.

The reason i tried trashing those files was as a last ditch attempt because it has "something" to do with AFP from some documentation i was reading about AFP plain text password issues.
 

pco2002

Registered
I figured out how to replicate this error; there may be more ways than one but this is what i did:

When i disabled the "send pwds in clear text" option via the Connect to Server dialogue box i got the error. Performing the aforementioned solution worked however i only trashed my home prefs. The client = 10.4.2, the server = Windows (don't know the exact version).

Philippe
 
Top