Connecting Imac G5 to a Linksys Wireless Pc Network


I recently purchased an iMAC G5, with wireless 802.11G built in. I have an existing wireless network, consisting of an Emachine, Dell, and Compaq laptop all connected to the internet (wirelessly) through a Linksys 802.11G router. During setup, the iMAC found the router, and was able to get online. In fact, I have no problem getting online at all. I DO have a problem connecting to the other computers in my network to transfer data (MP3's, etc). I'm wondering if this is due to the file format/operating system differences, or something else. On the iMAC, when I click on the "Macintosh HD" icon, and chose "NETWORK" I can see my home network name as a folder. When I open the folder, I can see icons with the names of the other computers connected to my home network. However, when I click on one of them, it pauses for quite a long time, then asks me if I would like to "Delete or repair the alias," referring to the name of the icon. It's frustrating to see them there, and not be able to access them. Can you help, please?
What operating systems do you use on the respective computers (Mac, Dell, Emachine and Compaq)?

There is a problem with samba and newer versions of Windows filesharing, in that Samba can't handle encrypted passwords the way that Win Server 2003 does, so you have to enable clear text passwords. Not the best idea on a wireless network, but if you are encrypting network traffic via WPA that shouldn't be too dangerous.

A bit difficult to really say much more, not knowing what you're running...

Here's a few of pages you might want to check out:
Thanks so much for the info. I eventually got them talking. Now I'm working on file sharing. All my PC's are running Windows XP Home, and my iMAC is running OS X. I just gave my son a 14" iBook for his birthday, and we've successfully networked it with the everything (except the laptop. That seems to be the one hold-out). The problem now is sharing my printer with the Macs. Thanks for the articles... They were great!