Connecting internet to 2nd ethernet port on Xserve

damo_burns

Registered
At the moment, I have an ADSL modem/router (1 port) connected to my switch (ethernet port 1 on the server and all my clients are also connected into this same switch). ADSL router has IP address 192.168.2.222 (assigned manually - outside my DHCP range). X Serve operates as DHCP for everything else and I put the default gateway as 192.168.2.222. Internet works fine on all computers (including server).

But I want the ADSL modem/router to be connected to ethernet port 2 on X-Serve (not straight into the switch). If I just unplug the ADSL router from the switch and plug it into port 2 of the X-Serve, the server can access the internet, but all clients can no longer.

Anyone have *any* clue how to fix this?! It doesn't seem that complicated, I feel I have done everything right. Any ideas? Cheers.
 

tjoneslo

Registered
Let me make sure I have this right, you setup is as follows:

Clients/switch ------P1 ----Xserver ---- P2 ---- ADSL--->Internet

I have a similar situation in my office using Linux. This turn the Xserver into a firewall. But to get it to work properly you need to have a different IP address for P1 and P2, and you need to configure IP forwarding and/or Network Adress Translation (NAT) in the XServer. I'm not exactly sure how to do this on the XServer, perhaps someone else can help. But this should give you a starting point to look things up.
 

slooksterpsv

MacTechie17
In Sharing->Internet, you could configure that up, see if that works. If not, I'm not sure either how to setup forwarding.
 

taylorlightfoot

Registered
In Sharing->Internet, you could configure that up, see if that works. If not, I'm not sure either how to setup forwarding.
Seeing as his computer is an XServe, I am sure he is running OS X Server on it, and OS X Server does not have Internet sharing as an option in the System Preferences.

He must use Server Admin and set up DHCP the way he needs it for his LAN and then he must go to the NAT section and set that up.

I hope this helps some
 

Go3iverson

Registered
Two things to keep in mind:

1.* Mac OS X will always expect the internet connection to be on the first interface.* If it is not, oddities may ensue. :)

2.* To see if you can swap this around, go into System Preferences and move the second built in ethernet to the top of the list of interfaces.* That interface list is actually weighted and reflects the order that the system will use them.

You may also want to look at the Gateway Assistant that you can use with Mac OS X Server.* :)

Hope this helps!

Michael
 
Top