Connecting with AppleTalk

SvMp

Registered
I have a problem connecting to my other Macs in the network.

When I enable Appletalk and choose the windows "Connect to server " with menu "go -> connect to server", and I choose "Local network", the computer will search forever without finding something.

I have two Apple talk computers: 1 Powermac 7200 with OS 8.1 and a Windows NT Server with Appletalk services installed. From Mac OS 9.0.4 everything works fine, but from Mac OS X I can't find my servers.
Appletalk is enabled.

What can I do?
 

brianmiller

Registered
According to the booklet that came with Mac OS X PB you must enable File Sharing over TCP/IP in OS 9 in irder to communicate back and forth between OS 9 & OS X PB computers.

If it still doesn't work for you don't get too frustrated... I haven't been able to get it to work either. Actually, when I clicked the checkbox in OS 9 to enable sharing via TCP/IP my Mac OS 9 machines all locked up. Might be some major incompatability here.

Best,

B,
 

SvMp

Registered
But that means that Mac OS X can't communicate with computers that have filesharing though AppleTalk, for example Macs with older Mac OS-es.
If you can't use AppleTalk to access files on other Macs, why is there a tab "AppleTalk" in the network control panel?
 

Laurent

Registered
Hi,

I have the same problem.
I have a Ethernet AppleTalk network with a few iMacs and G3 beige. Included the printer, there are all connected to a 10Mb hub.
AppleTalk works fine in MacOS 8.6 and 9.04 (this is my computer). But, in MacOS X beta, only the printer is recognized. So, I can print perfectly but do not see any other computer in any Appletalk zone.

Laurent
 

popey

Registered
To see a mac that share files over TCP/IP, you must enter his IP adress in the connect to serveur window, or set the comuter in the NetInfoManager
 

@:-)leX

Registered
Hi, Your note struck a chord.

I have also had problems with connecting to OS 9.0.4 Macs on the same Ethernet network as my OS X Mac. OS 9 Mac's see each other and by entering the IP address of the OS X Mac, in the chooser of OS 9, I can access the OS X Mac without problems. OS X Mac's see each other flawlessly, Apple K -> Local Network -> Local Services -> Computer Name. Select the other OS X Mac and your in. With the URL entry box at the bottom of the connect screen showing the afp:// address defined by the host's IP address. If I type in the afp:// address with the IP of an OS 9 Mac, OS X just ticks away forever (well at least 20mins and I got bored).

TCP is configured correctly on both 9.0.4 and X Mac's and AppleTalk is going over TCP on all OS 9 Mac's on the network. In OS X AppleTalk is active and working fine to other OS X Mac's so I can only figure that X to 9 sharing does not work.

If anyone can shed further light all comments welcome.


@:)lex
zifnab@mac.com
 

Kjell

Registered
I had to try several times before I got my AppleTalk network to work. First I had a problem getting file sharing in osx to start, but that solved (how? suddenly it worked)everything went smoothly afterwards.
In OS9 machine: configure the TCP/IP on the OS9 machine to connect through ethernet MANUALLY, and enter a IP adress (eg 169.134.0.1) and a net mask (255.255.0.0). Of course I set the file sharing to accept TCP/IP calls too.

In OSX machine: set the IP on the OSX to a manually entered 169.134.0.2 with a net mask value of 255.255.0.0!
Then connect to server using the IP address of the OS9 machine. Voila, I could see the OS9 machine and connect to it. Sorry if I am a little vague here but I am reconstructing this from memory on a PC can at work. Hope it will help someone.
Addendum:
I do encounter some problems with connecting to the OSX machine from the OS9 machines. The network browser finds the OSX but refuses to mount the volumes on it. I have to go to the Chooser, turn on Appleshare and write the IP for the OSX machine. I can't get aliases to work either. The volume can not be found...

Kjell

[Edited by Kjell on 10-18-2000 at 06:29 AM]
 

macboy73

Member
Originally posted by SvMp
But that means that Mac OS X can\'t communicate with computers that have filesharing though AppleTalk, for example Macs with older Mac OS-es.
If you can\'t use AppleTalk to access files on other Macs, why is there a tab \"AppleTalk\" in the network control panel?
AppleTalk is just one of a million things in OS X that isn\'t implemented yet. We just need to wait. And wait. And wait some more...
 

strobe

Puny Member
AppleTalk is supported for printing.

AppleShare is supported over IP

AppleShare over AppleTalk is NOT SUPPORTED (yet?)
 
Top