Coremidi Issues


After installing the Apple Security update 2005-008 in 10.3.9 I started receiving messages from my audio sequencer (Cubase) stating :

Could not connect to coreMIDI. You should restart your system.

I tried opening Audio / MIDI setup but it constantly crashes...I also tried trashing preferences and repairing permissions, reinstalling the MIDI drivers for the controllers I use, everything!...please if anyone can help I would appreciate it.
I get this message nearly every time OSX gets a security update. I fix it by uninstalling my M-Audio drivers (I have two devices, 1 midi and 1 audio and I have to do both) and then re-installing them. I've found that I have to do restarts in between deleting each driver, then restarts between installing each new one. The devices need to be disconnected from the mac when you do this. Every now and again (like now) I search to see if there is a fix for this but haven't found one yet... but I did find an updated driver, so maybe this is the fix!

I don't know why this happens or if there is any way to avoid having to reinstall the drivers everytime, but that's the only way I've ever been able to get over the problem..

Nothing else in my system is ever effected by this, just the M-Audio device drivers. :(

I get to dread the security updates!
My life is audio and MIDI ... had lots of issues with M-Audio on the Mac until they got cozy with Digidesign. Then, suddenly, the drivers (and the web pages) seemed to have gotten a serious housecleaning. So, if you haven't updated your drivers lately, that might fix it.
I know this is a bit out of date now, but I found a cure for this error (in case anyone is still looking for a solution...)

I spoke to M-Audio tech support and they explained that unless I upgrade my OS I will keep getting these errors about not being able to access core midi.

It's something to do with OS 10.3x - if you upgrade to 10.4 the errors stop happening every time Apple release a security update. I don't know what happens with Leopard as I've not upgraded to that but 10.4 works OK :) ...