Corrupt Disk0s1? Worry? No Worries?

Doctor X

Registered
My system is what it is in my signature. The Int-HD is a Seagate 1TB SSHD (Solid State Hybrid Drive) SATA 6Gb/s 64MB Cache if that helps. I back up everything on two clones so all is safe.

Out of the blue I receive an error from my Disk Warrior "missing resource."

Boot to a clone to check things out I inspect the drive/volume first TechTool Pro 8b: no problem with HD or the volume. No Problem.

I then use DiskWarrior which gives the same error when I try to "SMART" test the drive. Hmmmmm . . .

Disk Utility gives the following:



Before this time, whenever I felt the need to check things, the disk0s1 is grey and checks out. I one of my clones attached at you can see its disk2s1 which does check out fine.

Otherwise, everything is fine. All of the other parts test out fine.

Snooping around the Interwebz I find this may be the EFI partition and not a lot of advice about it.

So . . . should I care?

I suppose I could wipe the Int-HD and just rebuild everything from my clone, but if I do not have to do that, I would prefer not to waste the time doing it.

________

For the hell of it I decided to try El Capitan as in my signature now. While every thing seems to be find apparently the EFI partition was not fixed.

--J.D.
 

Attachments

Last edited:

Doctor X

Registered
I don't have a clue about your issue, but I do admire your disk naming convention.
With all my searching I have been unable to come up with a answer as to whether or not this is a problem. If it is "OHNOES UR HD GONNA DIE!!!111!11ELEVENTY!"
then, fine, I have my clones, I will clone more frequently, and start threads about "should I get that 1TB SSD rather than the now very inexpensive hybrid?"

One guy just deleted it and noticed nothing which caused techheads to panic without naming a reason. To "replace" it requires:

  • 1. A separate OS Boot-Up USB "stick" disk.
    2. A rubber band.
    3. A number of steps involving Terminal--which more than one commentator noted, "oh, you made a typographical error" while the original reply noted "you can utterly destroy your data."
    4. Stop watch.
    5. Heart of a small, Cute Orphan with a Song in Said Heart and a Head Full of Dreams!--The later of which you do not need. Just discard the head.
    6. A Ruler.
    7. No indication as to why this is a problem.

this should either work, help you break the speed of light, destroy everything, or IA! IA! CTHULHU FTAGEN!

My Big Question was always "should I care?"

Since I have numerable clones, and a few spare parts from the nearby orphanage, I simply "wiped" the drive. This will not wipe out all of your sectors on a HD.

So I reformatted the HD as a FAT+ . . . wiped it . . . then properly formated it for Sane People. Seriously. So I rebooted with my Lion Recovery which I had done before all of that. At that stage, the Lion Recovery Disk Utility could NOT fix that partition. THIS time it recognized the error and fixed it.

Loaded Lion, then updated to El Capitan--which I can at least say is no longer as odious as it was now that updates to software and all of that are available.

Booted to The Clone--External HD of Doom--ran its Disk Utility and no problem. BUT Disk Utility after Yosemite does not allow you to "see" and individually check such partitions without Terminal and at least an arm and a leg--of an orphan of course, I mean, Apple Tech is not unreasonable.

Still, El Capitan check of the Int-HD in its details states the EFI partition is "fine."







. . . wait for it . . .

Check with Disk Warrior?

Same error.


So Unless Someone Tells Me This is a Problem to Worry About

as in, it will propagate like a Belgian Bunny of Questionable Moral Fiber to affect your data, destroy your Hard Drive, or summon the Crawling Chaos

I Shall Simply Turn Off the SMART Check of Disk Warrior.


--J.D.
 
Last edited:

Doctor X

Registered
Solution?

It is basically impossible to erase the EFI and Recovery partitions unless you are in Mavericks and try really hard. I know this because the one actual discussion on this involved someone who did just that. So after all of this I wanted to confirm my Firmware updated. The particular model had an update released about a year after it was made.

Apple Support allowed a chat on that subject and they confirmed my current Boot ROM version is the correct one. I then asked about this whole crapola and, after consultation, they suggested:







. . . wait for it . . .


"Ignore it"


--J.D.
 

Cheryl

Rosie Moderator
Staff member
Mod
It is comforting to know that a program designed to protect is throwing errors that we are to ignore......NOT:confused:
 

Doctor X

Registered
Granted, I would state that I probably was not dealing with the Super Qualified Techie--someone working a Chat Function--but said Not So Super Qualified Techie understood the problem. I just needed to know that a corruption would not propagate to lead to the Belgian Invasion™ and that does not seem to be a problem. :confused:

I am surprised that after wiping the drive and all of that the Lion Recovery partition's Disk Utility not only recognized the "error" in this EFI partition, it . . . now . . . could . . . repair . . . it!!:eek:

Heard from Disk Warrior. They calmly replied:

The <missing resource> message indicates that you need to reinstall DiskWarrior. I'd like to send a clean installer to you.


Buuuuutttttt . . . would it not find the same error on external clones?


--J.D.
 

Doctor X

Registered


Well . . . I may have written too soon. After transferring everything after all of that, I did not realize that formatting the Int-HD [of Doom!--Ed.] as CASE-SENSITIVE journaled would mean a few necessary programs would not work on it!

*Pours some coffee . . . discards it for wine . . . starts process over again*

This time I just reformatted from my clone's Disk Utility . . . then transfered directly rather than going through the [CENSORED--Ed.] of reloading Lion then upgrading to El Capitan . . . blah . . . blah.

Everything works!


Just for the hell of it, I checked everything with Disk Utility--> :cool:

Checked everything with TechTool Pro 8--> :D

Then, "why not?" ran DiskWarrior


DiskWarrior-Director.jpg


I am running a Surface Scan of the drive with TTP8 as we write
.

Now, obviously if I get "Bad Blocks" I am [CENSORED--Ed.] and need to get a new Int-HD.

BUT IF IT BE CLEAN may I ignore it? So far so good in the check.
--J.D.
 

Doctor X

Registered
Very belated thanks on that.

As you can see, it has been nearly two years and my Original HD of Doom is still pooping along, happy, and laughing at DW and TechTools.

Which just means the Belgians are lying in wait. . . .


--J.D.
 
Top