CVS for X

sly

Registered
Hi,
Has anyone got CVS working MacOSX?
Because I use it work, and wanted to install it on X, as it is the only thing we use on our linux machine that I cant have on X.
If so any links or makefiles to download.
It is one great Web Dev machine :)
Thanks
 

atoms

unior Member
It works for me. Installing it must have been pretty trivial because I don't even recall doing it!

I know that I did not install the whole of Darwin. I have tried to do that (without success) to get pgp.
 

BenW

Registered
I thought it might be--I looked and found CVS manpages, but I couldn't find CVS itself. I also found the manpage for Perldoc, and it isn't there either. Which is dead strange, because I don't think there was anything wrong with the install... (didn't make any objections, anyway). Oh well. It's vaguely comforting that Apple did in fact do those things right in general, and it's just my install that's screwed up. :( Unless anybody cares to tell me where to look for it? (likely pointless, actually--I'm booted to OS 9 right now and I searched perl and cvs in Sherlock, and they ain't there.)
 

atoms

unior Member
so you type "which cvs" at the prompt (in the terminal application, in OS X) and get "cvs: Command not found."?

 

iRock

Registered
ehh, yeah, no offense, but i'm guessing you're just smoking crack. If you want instructions on how to configure and get stuff via cvs go to http://www.xfree86.org/cvs/ you can do either the pserver or ssh setup. cvs is a command line program, it's not graphical. i don't think sherlock searches all the files, i think it skips over some folders and some unix files to kinda hide them from the user. That is likely the reason you couldn't find them...but i don't know, i just find difficult to believe cvs isn't really on your system. CVS is preinstalled on os X, my guess is that it is there, you just don't know how to use it. (again no offense)
 

BenW

Registered
That's a nice turn of phrase... "no offense, but you're an idiot." Sherlock under OS X may try fooling the user, but under OS 9, those are all just folders as far as it's concerned. Yes, half of them are invisible folders, but that isn't a problem for Sherlock (unless you try to open something in one of them directly, which won't work). Perl is there, slightly over half the modules for the standard distribution are there, and perldoc is not; the man pages for CVS are there, but CVS itself is not.

I work in a development environment on SGIs all day--I'm by no means a CVS expert (or even a full-bore Unix expert), but I do have some vague notion of how a command-line works, so please be careful with how broad a brush you tar.

[removed paragraph based on misreading of post from atoms]

[Edited by BenW on 01-30-2001 at 02:38 PM]
 

iRock

Registered
again no offense was meant, everyone is an idiot every now and then. i seem to smoke crack frequently. i'm still thinking cvs is installed and you just haven't found it on your system...you don't need to try to find it though. atoms asked what happened if you typed "which cvs" and you didn't really answer that question. you could even try typing cvs and see what happens. If cvs is there somewhere it should say you need to read the cvs man pages or give you an example of the formatting or something.
 

russgold

Member
Well I have tried this myself. I typed "cvs" at the terminal prompt and got "cvs: Command not found."

I typed "which cvs" and got the same answer. So I have to believe that it is not installed in OS X.

If I download the source install, is there a compiler built in so that I can use it? Execute source works great in perl, but...
 

BenW

Registered
I installed the Developer Tools and instantly my life improved greatly--CVS, gcc, and all manner of Perl modules that were missing all showed up. If that doesn't work, you can find CVS and gcc at the Darwin site I mentioned above (and documentation at http://www.cvshome.org.) But I'm pretty sure it's in the Dev tools.

Good luck!



[Edited by BenW on 03-19-2001 at 12:15 AM]
 

russgold

Member
Unfortunately, I cannot download 97.7 MB through my 28.8 modem. It won't reliably hold a connection for the 8-9 hours required, and there is no way to restart the download from the middle.

Is the compiled cvs application available by itself anywhere? Or do I really have to wait for my DSL line before I can use cvs?
 

razortooth005

Registered
I must be an "idiot" too. Last night, I finally got my MacOS X 10.1 box to be visible on the public Internet again (after getting my @home service disconnected a few weeks ago) and ready to set up a CVS server. I couldn't find CVS anywhere on my system!!!
It so happens that I am Unix literate, and searched the entire disk(not using Sherlock) and only found the cvs man pages.
What gives :confused: ?

Every post or article I've seen says it comes with OS X. But apparently there are two of us who didn't get CVS with the default installation.

Anyway, sounds like the solution is to join the ADC and download
the tools. I'll give it a go.

BTW, this website rocks!!! This is the first really good source of
MacOS X/Darwin techie info that I have found.
 

jgade

Registered
I do not claim to know, whether CVS comes preinstalled on MacOS X 10.1, however I have Mac OS X 10.1 installed WITH the developer pack (downloaded from developer.apple.com).

And I'm happily using cvs, so my guess is that you need the developer pack in ordrer to get cvs.

/johan
 
Top