D-link Dsl 300-t Modem With Airport Express

My question is half asked by an earlier poster...

http://www.macosx.com/content/faq.php/q7950/Dlink-300t-Dsl-&-Airport-Express-Problems.html

...but the resolution to the problem, if any, was not added to the post.

I have the same set up as described previously, a D-Link DSL300-T modem and an airport express base station.

I can connect to the internet using the modem connected directly via an ethernet cable. In this situation, the modem passes through the external IP address so that in System Preferences | Network, the IP address shown when using DHCP is the external one. This works perfectly well.

Adding the airport into the chain however, presents one of two problems.

1) With the airport set to distribute IP addresses, and to connect via DHCP, the airport is able to see the IP address as provided by the modem (ie. the external one), the computer sees the IP address provided by the aiport (an internal one by default in the 10.0.0.1 category, or thereabouts, I'm not in the vicinity of the airport at present to check). All seems well, but the computer cannot see the internet. Error message: "You are not connected to the internet"

2) To overcome (1) I told the Airport NOT to distribute IP addresses, and act as a bridge. In this case the external IP address is passed through both the modem and the airport, arriving untouched at the network pane of system preferences. In this fashion, it is possible to connect to the internet via airport, albeit in a very unreliable way (repeatedly drops offline). Snag is, since only one IP address is now distributed by airport, only one computer can connect at a time.

Can you help? I'd clearly like to correct point 1 so that the external IP address is kept external by the aiport (or better still the modem) and internal IP addresses are provided to any computer that needs them.
 

arobinsonuk

Registered
Hi there,

I have this very same problem, identical hardware, and have fallen back on the same, rather unsatisfactory, solution. Have you been able to resolve it since you first posted your query?

Thanks for your time,

Alastair.
 
Top