Deleting/uninstalling Omniweb

David R

Registered
OK, so I play with Omniweb and I decide to get rid of it.

In MacOS 9 you just drag the file to the trashcan. I can't do that in OS X. It tells me that the file cannot be put in the trash because it cannot be deleted.

Wonderful. How do I delete/uninstall it?
 

TimOmernick

Registered
You may not have the appropriate file privileges to delete OmniWeb. Also, check for a Remove option when you open the .pkg file in InstallerX... Too lazy to check now, but I seem to recall there being one.

-Tim
Software Engineer, The Omni Group
 

David R

Registered
Tim, thank you for taking the time to reply, but in all honestly, what you told me means absolutely nothing to me.

Installer X. Uh?

File priviledges? I installed it using my only account, the administrator account, and it is using this account that I am trying to drag it to the trash.

Don't get me wrong, it's a nice browser, and most likely I will keep using it. I was just trying to figure out how to install/uninstall apps using OS X.

I look forward to hearing from you.
 

doppelbock

Registered
The Installer app he's talking about can be found in the Applications->Utilities folder...launch it and give it a try....

As for file permissions....

try logging in as "root" using the password you assigned to your admin account...that may work.


also, there will be an improved version of omniweb very very soon....evidently the prior beta which worked under dp4 would not function under the beta, and they puched beta 5 out as quickly as possible so people had something (else besides IE) to use...the next version beta 6 should be a lot more stable.

Omniweb is a great browser....certain to become the one of choice for me....
 

sverre

Registered
this is because OmniGroup set the permissions wrong on the file. If you look at all the other applications in that dir with the inspector (Sharing tab) you see that the admin group (all administrators) have write access to them, and thus can delete them.
With OmniWeb only the owner (ie root) has write access. To delete it you have to login as root.
Later you can probably remove with the installer, but I seem to recall reading that it doesn't support it currently.

OTOH, making applications not writable makes them much less susceptible to virii.

[Edited by sverre on 09-18-2000 at 11:30 AM]
 

David R

Registered
So I have to get into the terminal and chown or rm as root. While this is not a problem for me (even if I didn't think of checking on that, I will as soon as I get home since I didn't enable telnet access to my box just yet) I just hope that this will change in the near future.

I wouldn't want users have to open a terminal window and start typing voodoo to remove files.

In this case, and I should probably submit this to Apple, if you cannot delete it, it should say that you do not have permission to delete the file. Please either login using the "whatever" user account, or click the lock to become the administrator (the equivalent to typing su in the terminal)

I realize this is a beta. But it is also a Macintosh, which is supposed to be easy to use.

Anyway, I'll try it at home and post my findings.
 

David R

Registered
anyway, I did an rm as root and it worked.... thanks for the heads up

I hope the installer is fixed in the near future
 

MacFan

Registered
With OS9 on your box still you can boot into it and find the Omniweb app in the OSX folder that you put it in and simply throw it away and when you boot up into OSX it will no longer exist. Just another workaround.
 

sverre

Registered
That lock button in the window probably won't happen since it's not that easy to get full privileges.
The programs that let you do this startup with root privileges and then (hopefully) disable them until you press that lock icon. IMO the fewer applications that does this the better (it's a security risk after all), and desktop, as an app that runs at all times, absolutely shouldn't.
I agree that it probably should say what user does have privileges to remove the file though.

PS.
I'd recommend you to use the ssh server instead of telnet since then you don't have to send your username/password as plain text over the internet. To do this however you must edit the file /etc/hostconfig manually and add a line containing SSHSERVER=-YES- (and reboot or start it up manually by typing sshd as root)
Apple don't want you to access /etc/ (they could at least've let us use the "Go to folder" command to get there) so the easiest way is probably to use emacs in terminal.
DS.

[Edited by sverre on 09-19-2000 at 07:48 AM]
 

David R

Registered
Yes, I use ssh because the passwords are sent in plain text over telnet, but I always call it telnet regardless of how I connect. Call it a bad habit! :)

I don't really care how Apple handles this error message, as long as it is handled better than the way it is handled currently.
 
Top