desktop crash loop...

rinse

www.visualrinse.com
my desktop application just keeps crashing again and again, it doesn't even fully launch before it crashes.

this is in my console:
Mac OS X Console
DOCK: CFMessagePortSendRequest returned -2
DOCK: CFMessagePortSendRequest returned -2
Dec 10 13:49:06 localhost loginwindow[396]: Finder quit with exit status of 11

Dec 10 13:49:37 localhost last message repeated 25 times

Dec 10 13:51:39 localhost last message repeated 83 times

Dec 10 13:54:20 System Preferences[637] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:54:20 System Preferences[637] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:54:20 System Preferences[637] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:54:20 System Preferences[637] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:54:20 System Preferences[637] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:54:20 System Preferences[637] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:57:15 System Preferences[761] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:57:15 System Preferences[761] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:57:15 System Preferences[761] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:57:15 System Preferences[761] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:57:15 System Preferences[761] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 13:57:15 System Preferences[761] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Dec 10 14:01:40 localhost last message repeated 397 times

Dec 10 14:11:43 localhost last message repeated 368 times
:( any ideas on what to do about this?

oh, and my terminal app seems to be hosed as well...

i get this on launch of that:

"[Process completed]"
:( :(

what is going on here?
 

jove

Member
I have no idea what is going on but I am interested in knowning how you got there. Did you post the bug report to Apple's feedback?
 

rinse

www.visualrinse.com
well, i changed my default shell to csh in my terminal prefs... now i don't have tsch :( but at least the terminal works.
my tsch must have gotten corrupted. i'm going to rm the old tsch and reinstall it.

still about my gui:

my desktop is still crash-looping after switching to 9 and back to OSX.

my desktop is still crash-looping reinstalling to OSX.

my desktop is still crash-looping after switching to 9 and back to OSX and using disk first aid.

:(


 

zpincus

Registered
The "terminal app process completed" problem has cropped up here before. Search for "process completed" on these forums -- it is a very very common bug, and some people seem to think it is caused by Norton hosing stuff. But there may be other causes. (Have you used Norton disk utilities of any sort lately?)
Short answer -- reinstall OS X. The installer is rather smart, and youwon't lose anything. This will probably fix both problems.

Zach
 

VGZ

Registered
Sounds like a picture is causing the problem.

Dec 10 13:54:20 System Preferences[637] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Did you change your desktop picture before the crash loop? If you did you might try removing the picture from the hd.

Sorry I can't be more helpful :(, but I hope this helps :),
 

rinse

www.visualrinse.com
Originally posted by VGZ
Sounds like a picture is causing the problem.

Dec 10 13:54:20 System Preferences[637] Warning: TIFF image with unknown extra samples assumed to have unassociated alpha. RGB values have been premultiplied
Did you change your desktop picture before the crash loop? If you did you might try removing the picture from the hd.

Sorry I can't be more helpful :(, but I hope this helps :),
thanks for your input... from a thread on Macnn (eternally desktop bouncing!! -search for it, sorry don't have the link) i gathered that it must be corrupt preference file... some com.apple.finder.plist, or com.apple.desktop.plist.... which means i should hacking and stuff... blah.

probably.... but i feel so foolish in a terminal, so unproductive... arrgh.

i have a CLI inferiority complex, and it's hampering my computing! gah!

im in 9 right now... trying to get sh*t done... so what did i do?

i downloaded a SSH capable telnet app and hope to play a bit in it, while in the friendly confines of 9... maybe ill get a bit more comfy in it, and actually wanna learn X.

:(

 

rinse

www.visualrinse.com
Nearly every preference i had set has been reset... the drives, the dock icons everything... time to customize again.

it seems all my service prefs like SSH being activated and stuff... are all okay it seems. haven't checked the other user accounts i set up yet.

is there a way to write a restore scripit that will prevent headaches the next time this happens...

maybe apple could write something like that "preference sets."... or maybe someone else could...

or someone else has and it's expensive?
 
Top