Desktop Not Loading After Login


We purchased a new Powerbook that came preinstalled with Tiger, and after setting up its user accounts and configuring the airport for our wireless environment, we moved a good deal of content from the user folders off another Powerbook running Panther. We installed 10.4.1 and everything was humming.

Then the machine was brought home where an Airport Base Station was serving up another network, and as soon as the user approved the "do you want to connect to this network" message, the machine went beach ball on him. So he rebooted and logged back in...after which he received nothing but background. Nothing else on the desktop. The mouse still tracked, but there was nothing to click on.

So he brought the laptop back to the office and got the same result here. So I logged in using an account I had created for myself and got in just fine. After which, I could logoff and log him back in with no trouble. All I had to do was login and logoff and suddenly his desktop would work.

I Googled some and decided that it could be waiting on a network response or something so I disabled the IPV6 operation on all network devices. I ran the Fix Permissions but minor changes reported. As long as we were in the office, it worked fine until he brought the machine home.

When at home, the laptop would presumedly hear the wireless network and freak out, so it would never come up past the login. So I upgraded the software on a surplus Airport Base Station and configured it for the user's home so he could swap out his wireless network before booting, but he never got the chance to try this.

Now, for some inexplicable reason, I can't get in with any account for any reason. Occasionally, the machine will hang on the spinning beach ball while displaying the Login page, preventing us from even logging in. That doesn't seem consistent. I can boot to single user mode but I don't know where to start. I've tried booting to safe mode and the closest I can come is getting the dock at the bottom of the screen, but Finder isn't loading and nothing else will come up, save the Dashboard (the only thing that will respond.


I don't have an extensive Mac background... I come primarily from Windows and Linux platforms, but I've been getting something of a crash course here lately.