Developer Installation Problem

CerealKiller

Registered
Installed the RC over PB last week without problems. I had never installed the Developer Tools in PB but need to install the RC Developer Tools now.

The installer reaches approximately 1/2 way, states that there are 9 minutes remaining but never completes. I let it run overnight and this morning it still says 9 minutes remaining.

Out of frustration I formatted and reinstalled OS X RC so that any remaining PB problems would go away. And again I was stuck at the 9 minute point.

The system is stable. CPU utilization is near zero. The Developer Tools CD got ejected. I copied the Developer Package to my disk, quit the installation and ran from disk. Still get to the 9 minute mark and don't proceed beyond.

I have some other software that requires the Developer Tools.

Still installing....
 

robert

Registered
I have had the exact same problem. I've even reformatted the HD, reinstalled 9.1 and then X, only to realize that it didn't help at all.

Same thing happens with OSX PB Dev tools, but of course I've now learned that I shouldn't have tried that... :) .

Anyway - a solution to this problem is sorely needed!

/Robert
 

robert

Registered
It turned out to be a faulty CD that caused my problem - with a fresh disk image from a friends CD everything went well!
 

CerealKiller

Registered
I still can't get it to completely install.

However, I read some posts on Apple's discussion board. I have managed to get almost completely installed. I found that you must log in as root. Simply having administrative rights isn't enough. Apple's documentation doesn't say anything about this...

The only other ballsey guy here who installed OS X had no problem whatsoever installing the Developer Tools. Go figure that one out!!
 

CerealKiller

Registered
I had to boot from the Mac OS X Installation CD. Change the root password. Restart Mac OS X. Log in as root with the new root password. Then I was able to successfully install the Developer Tools.
 

capncrnch

Registered
Ive tried installing the Developer Tools from the Cd that came with the OS X final but I got no love there. Install halts when it gets to selecting the destination disk. my startup disk is greyed out.

I copied the Developer.pkg to my startup disk. Same issue.

I chmod 777 Developer.pkg. (anyone can play with it now) and now i dont need to click on the padlock for the install but my startup disk is still greyed out.

I called Apple Support. They didnt help at all. They said I had to have OS X installed in the first 8 gigs. Well, OS X is the only OS I have on my hd. They suggested I check the TIL...

If anyone could help me Id appreciate it.

Im running an Imac Rev A 233MHz.
Modifications Ive made... I have a 20gig Maxtor HD. 256 MB ram. I replaced the tray cd-rom with a dvd drive.
 
Top