Development tool install problem

MrComputer

Registered
When I try to install the development tool's package I get an error saying that the "installer couldn't install xxx to path" or something like that.

Anybody else seen this? Know any solution?

MacOSX is installed on the same partion as MacOS9 (only one big partion on disk)
 

endian

Dis Member
use omniweb to download and/or openup to expand it. explorer and/or expander destroys the archive.
 

MrComputer

Registered
It was the stuffit expander supplied with osx that messed up the install package. Using classic worked fine and the installation worked without any problems

[Edited by MrComputer on 10-15-2000 at 08:29 AM]
 

ArkadyChicago

Registered
I know I'm gonna get nailed for asking this, and rightfully so, but I don't care.

WHERE did the development tools go once they were installed, and WHAT was included? I didn't see so much as a Read Me file.

Anyone?

Thanks.
 

Tyler

Senior Member
Look in the root directory and you will see a Developer folder. The most interesting stuff is in there (ProjectBuilder, InterfaceBuilder, etc).

There are various other things (compilers, headers, libraries, et al) scattered all over the rest of your hard drive.

The bom (bill of materials) used to be (in NeXTStep times) an ascii text file that listed everything in the install -- it now appears to be ascii mixed with some binary so there is probably a tool (command-line??) that will allow you to read it.

I'm not at my system right now so I can't check -- I'll post another message as soon as I figure out how to read the bom.

Tyler
 

Tyler

Senior Member
Okay, I finally figured out how to read the "bill of material" (.bom) files on OS X.

/usr/bin/lsbom will list the contents of the .bom file.

So from a terminal window, the following line will list out everything that was included in the developer package.

lsbom /Library/Receipts/Developer.pkg/Developer.bom


Tyler

 
Top