Dictionary

rajkumar

Registered
Hi,

I bought a iBook recently. When browsing online, I found out about command-ctrl-D for lookup in Dictionary. When I tried it, it did not work in Safari. I crosschecked the keyboard shortcut in Systems preferences, that looked okay. Then I realized that I do not have a Dictionary.app in Applications folder. Highlighting text and using Ctrl-click to "look up in dictionary" does not work either. I tried installing Oxforddictionaries pkg from installation DVD, the installation went successfully but the problem remains. Please let me know if you know what's going wrong,

Thanks,
Raj
 

symphonix

Scratch & Sniff Committee
Are you running Mac OS X 10.4? Dictionary.app wasn't included in older versions.

Do you have Dictionary.app in the Applications folder now, or is it still not there? If you've deleted it somehow, you will need to do an archive and reinstall of Mac OSX, or use a program like Pacifist to retrieve it from the install CDs.
 

rajkumar

Registered
I have os 10.4.2. I do not have dictionary.app in my applications folder. I did reinstall from DVD, though the installation went successful, I cannot find dictionary.app anywhere.. Spell check does work in Textedit though..
 

applemaz

Registered
The dictionary application is in the widgets. You have to click the widget icon on your dock and then it should come up on the screen. If it isn't there, click the circle with the plus sign on the bottom left while in the widget screen and you should see a bar with all possible widgets on your system. Look for the Dictionary one and drag and drop it from there to the screen. You should now be able to use it.
 

bobw

The Late: SuperMacMod
The dictionary application is in the widgets.
There should be a Dictionary app in the Applications folder.

Boot from the Tiger disc and do a Custom install of only that app, if it's listed.
 

rajkumar

Registered
I tried custom install from Tiger DVD (Oxforddictionaries.pkg). Installation went succesfully, but nothing changed. There is not dictionary.app in Applications folder. Is there anything else I can try?
Thanks
 

MisterMe

Registered
If the installation was successful, perhaps you installed the Dictionary is a location other than the Applications folder. Just select the File > Find... menu item and search for Dictionary by name.
 

rajkumar

Registered
File> Find does not lead to dictionary.app. Is there any way to uninstall dictionary so that I can do a clean install from DVD?. Thanks.
 

RacerX

Old Rhapsody User
If you just need to install Dictionary.app, then use Pacifist. It'll let you install individual components from a Mac OS X install DVD (should work with 10.4 packages as Apple hasn't changed the format).

:rolleyes:

Or you could use OmniDictionary (been around since the Rhapsody days) and Nisus Thesaurus (been around since at least 10.2). These were the apps that replaced the Digital Webster (the app that Dictionary.app is based on) when Apple didn't include it with Rhapsody/Mac OS X.

OmniDictionary and Nisus Thesaurus both improve on the original Digital Webster idea, where as Dictionary.app seems to have been suspended in time from the NeXT days (like Apple just found it in a closet and just dusted it off :eek: ).
 

rajkumar

Registered
Thanks Symphonix and RacerX, Pacifist did solve the problem, I was just not looking at the right package to install. Thanks!
 
Top