Disable programs on OS X server

texastig

Registered
I have a OS X 10.2.8 on a server and clients ranging from 10.2 to 10.4. I locked down what programs a user was allowed to open from the workgroup manager, however I want to be able to allow the users with 10.4 access to the Dashboard. Any ideas how I would go about doing this since 10.2.8 doesn't have the dashboard in it?
 

bvd

Registered
texastig said:
I have a OS X 10.2.8 on a server and clients ranging from 10.2 to 10.4. I locked down what programs a user was allowed to open from the workgroup manager, however I want to be able to allow the users with 10.4 access to the Dashboard. Any ideas how I would go about doing this since 10.2.8 doesn't have the dashboard in it?
Launch WorkGroup Manager on your OS X 10.4 client and connect to your server. You should be able to add any program on your client machine to the list of acceptable programs.
 

texastig

Registered
I tried to do that a few minutes ago. I couldn't find workgroup manager on the client, but I tried connecting to the server and then launching workgroup manager from the utilities on the server. I was able to drag dashboard into the apps that are allowed. The client was able to open dashboard but the widgets just close when they are clicked on.
 

texastig

Registered
Finally figured it out. There is a checkbox when choosing apps to allow approved apps to open nonapproved apps. After allowing that Dashboard works fine. One other note is that Entourage (yech) also breaks if this is disabled. Thanks for the help!
 

texastig

Registered
I'd say that too, but I'm not sure what is was trying to access. I had Entourage in the list of approve apps. I f you have any idea what it might have trying to access, do tell :) I'm very close to wiping OSX off both the server and clients and loading Gentoo instead. Management is so much easier... hee hee :)
 

slooksterpsv

MacTechie17
We had this problem with Font book, users couldn't add fonts, we fixed it by repairing permissions on the Server then on the Client. There is another way though, I think, have it to where an AppleScript opens the application, change the icon on the AppleScript so it looks like Entourage so that when the user clicks on it it opens the application for them. That could help, but probably not. Try deleting a users permissions or creating a new user and loading up entourage.
 
Top