Disk Utility cannt mount Macintosh HD

KA0802

Registered
Hi. A few days ago, my PowerBook G4 12inch has crashed. i can boot from CDROM and open Disk Utility. It recognizes the hard disk (37.3 GB TOSHIBA MK4025GAS). But when i click on Macintosh HD, it says 'Not mounted'. i click the 'Mount' button but it does not work. First Aid on Macintosh HD stops with an error message 'The underlying task reported failure on exit (-9972)'. i have tried PRAM clear but it did not help. i also tried PMU reset, but in this case, i'm not very certain if i could reset it because i hear no sound or anything. Is there anythink i can do? I would not like to erase the disk content if possible. Many thanks for your help!
 

becc

Registered
You can try DiskWarrior, Norton DiskDoctor, or Tech tool, for me the best is DiskWarrior, but, if that doesn't work and you want to recover the info try with an utility called DataRescue, then when you have recovered all your data you can re-format the HD.
 

TommyWillB

Registered
I used Norton religiously for years, but it's failed to make a credible transition to OS X. Don't buy it. Don't use it!
 

tumbleguts

Registered
Yes, both DiskWarrior and TechTool Pro are very good utility programs.

If when booting from the OS X install disks and using Disk Utility, you are still not able to access/fix the drive - suggests that the drive has severe problems. One of the above programs may be able to fix it...

You could try removing the hard drive and connecting it as a slave on a tower Mac - you would be surprised how often I've been able to fix drives this way.
 

KA0802

Registered
Many thanks to all who replied. i'm now writing from the revived mac. What i did is to boot from the installer CDROM in the single mode (command-S) and type a command 'fsck_hfs -fyr /dev/rdisk0s9'. Here the 'r' option was the key. i'm now deciding to buy DiskWarrior.
 
Top