Disk utility crash whilst creating new partition


Hi all,
On my MBA I tried to partition the hard disk - creating two equally sized ones from the existing 112GB.
Only 40GB are used at the moment. First Disk Utility only let me create a new one with 50 GB, but I went ahead.
Disk Utility crashed and now I have a big mess - looks like it worked in resizing the primary but I can't access the 'new' half.
This is the diskutil list output:

diskutil list
0: GUID_partition_scheme *121.3 GB disk0
1: EFI 209.7 MB disk0s1
2: Apple_CoreStorage 120.5 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s3
0: Apple_HFS Macintosh HD *52.4 GB disk1

Any idea how to recover the missing part?
It's OS X 10.8.2 on MBA 5,1

Thanks a lot,

Doctor X

This may seem like a stupid question, but did you back everything up? I would rather assume you did since--to my recollection--repartitioning with DU is destructive--wipes your data. I hear tell from the youn'uns with their fancy hotrods, bebop and Mountain Lion that this may not be the case.

IF you backed everything up, I would suggest simply starting again--erase the HD and then try to repartition it.

IF you did not--
--then the question is where is your data. If it is in the partition you can access, run along to your local convenience store/crackhouse that sells Ex-HDs, get one--if you do not already have one--and clone that. This way, you do not lose anything as you try to repair what happened. If that is successful--and it is something you should do routinely
--then simply erase and repartition then clone back "you" from your clone to the partition you wanted.

IF you have data on the partition you cannot access I would suggest:

1. Back up what you have not backed up which you can access.
2. Consider booting from an External HD--sure, you can use your recovery partition but then you are "on" your regular HD which you have problems with. Much faster and easier to be booted off of another drive. If you can do that--see advantages to cloning--then try to repair the drive from the External.

If that does not work then you have two other options:

1. Wait for a Guru who can figure out some more technical way to work through what happened--he may want crash logs and the like.
2. Consider a program like Disk Warrior--$$ but has saved volumes that otherwise cannot be saved. It may create a virtual disk of your data which you can then move over/save to your Ext-HD thereby allowing you to start all over again with erase and repartition.



I got all data backed up, I tried the CTRL-R and then re-install option, but it only showed one hard disk with 50GB to choose.

I haven't tried erasing the HD first though. Might give that a try later.