Dmg Files Not Recognized

AceMac

Registered
Hi,

Im having issues when attempting to open/mount all DMG files on Tiger. I get "the disk image failed cause its not recognized". Can anyone shed some light on this one?

Thanks very much.
Regards,
Marc
 

shagless

Registered
I too have had similar occurances with dmg files. Some work, others are saying they have output/input errors. Today trying to place a dmg file on my firewire drive in case i need it later said it could not copy because ..."some of these items...names are too long for the destination. Do you want to skip copying these items and continue copying the other items?" This puzzles me because I just had this dmg opened and used the files in it to replace other files on my hard disk. What is up with dmg files in Tiger?
 

shagless

Registered
Oh, I did get one of the problem dmg files to open using disk utility, don't know if that might help you out.
 

mpuk

Registered
There is a little app called mount that is quite helpful for unmountable dmg files. Don't have to use it too often anymore, but still keep it for those stubborn files...

http://mount.houchin.us/

Let me know if it works out for you...
 

barhar

Registered
Locate and select any '.dmg' file.
Do a 'Get Info' ['Command I', or 'Finder' - 'File, Get Info'].
Once the 'Get Info' window appears - locate the 'Open with:' section.
From the 'Open with:' popup menu - select 'DiskImageMounter', then click on the 'Change All' button, and finally - click on the 'Are you sure you want to change ...' Dialog Box'es 'Continue' button.

If 'DiskImageMounter' is not listed (in the popup menu), select the 'Other...' menu item.
Go to '/System/Library/CoreServices/'. Here you should fine 'DiskImageMounter'. Select it, then the 'Change All' button, and finally, the 'Continue' button.
 

dirtmac

Registered
I'm having the same problem as Marc. I've tried the "mount" utility and the suggestion barhar offered, but no luck! Anyone else have any suggestions?
 

barhar

Registered
Ok, shooting from the hip here ... consider this:

Run 'Disk Utility' from either your boot drive or by booting from the 'Tiger' installation DVD [or first Insallation CD].
Select the 'First Aid' tab, and then locate and click on the boot drive Icon [in the left column].
Click on the 'Repair Disk Permissions' button.

If a number of changes are noted - again, click on the 'Repair Disk Permission' button. You want as few change notices as possible.

Once satisfied that as many permission settings have been corrected, try double clicking on any '.dmg' file. Any positive result?

-----

If you have Roxio 'Toast' (v. 6.1.1 required for 'Tiger') run it, and try dragging a '.dmg' file onto its 'Dock' icon. Inside the main window the 'Mount' button should become active. If so, click on it. Any positive result?
 

refractions

Registered
...but just in case anyone else comes across this thread via Google, as I did, thought I'd put my 2 cents in.

I had the same problem with a couple of files. Tried the Mount program, DMG fixer, Disk Utility etc., but finally fixed the problem by repairing permissions *more than once* (as suggested by barhar) and then deleting the old .dmg file I was trying to install (the Last.fm software, in my case) then downloading again. this time, success! thanks for the tips all.
___________________
OS 10.4.11 on iBook G4.
 

Islarascador

Registered
This is almost certainly a .dmg file that was not downloaded correctly.
I was downloading .dmg files with chrome and could not get the system to recognize them. I switched to firefox and bingo!
(My system is a macbook pro 2.3 GHz Intel Core i5 running Lion - but this may be irrelevant)
 
Top