Dmg Mount Just Creates Alias to Nothing

I can't pin point when this started happening but I cannot install anything new on my mac! When I download a .dmg file and double click on it, it goes through the mounting motions of diskcopy but just spits out an alias to nothing - ie. either the hard disk or just restarts finder or something?? Has anyone got a clue what's going on? - I'm running Jaguar 10.2.8. Oh and another problem that's also turned up is that I can't empty the trash due to error 8062 - I have some applications that seem to be the offending items - old versions of MSN messenger.

Please Help!

Many thanks in anticipation.



Re: the trash... Have you tried holding down the option key while clicking on empty trash?

And have you tried repairing permisiions recently? Applications/Utilities/Disk Utilities
I've repaired the permissions it's made no difference. I think it may be they are running processes. How can I shut down processes that are not shown in the dock?


'How can I shut down processes that are not shown in the dock?', well - you can launch 'Process Viewer' ('/Applications/Utilities/' folder), set the 'Show:' popup menu to 'All Processes', click on any process, and then the 'Force Quit' icon button in the toolbar, ...
However, doing such is extremely dangerous and not recommended.

Try the following.
01. Launch 'Terminal' ('/Applications/Utilities/' folder).
02. Enter ...

rm -rf

... and press the 'spacebar' once after '-rf'

03. Click on the 'Dock' based trash can icon, to open its window. Position the window such that the 'Terminal' window is visible.
04. Do 'Command A' to select all the trash can's window's contents.
05. Click and drag the trash can's window's selection onto the 'Terminal' window.
06. Click on the 'Terminal' window and then press the <return> key. The trash can's window should now be empty.

If the above steps fails, repeat them - using ...

sudo rm -rf

... (yes, with a 'space' after the '-rf') instead of 'rm -rf '. You will be asked for your password - if you have one.

Now, gather all those alias'es, trash them, and then empty the trash.
Finally, double click on a '.dmg' file - what happens?