Dock Pinning


I installed 10.1 yesterday (I would have done it a week and a half ago, except my monitor died and I had to wait for a replacement), and noticed one strange anomaly. I logged into my administrative account (which is NOT the account I normally use) to do some administrative stuff, when I noticed that the Dock was hidden on the right side of the desktop. I turned off hiding, and moved the Dock to the bottom of the screen where I like it, but the dock remained pinned to the right side of the screen, rather than the center, which is where I like it.

I couldn't find any setting for where the Dock is pinned in the Dock preference panel. Does anyone know where it lives? Is it something I have to edit from the command line?

G4 Tower/500Mhz AGP
1280 Meg RAM
18 Gig Ultra2 HD
while this probably isn't the easiest solution, it is a way to get your dock back to the middle of your screen.

Go here:

get the scripting additions as noted (if you don't have them already). then run the transparent dock app. if you don't want it transparent, that's fine, i think you can still proceed and just add the other features (one of which is pinning). Once the app had done it's work you can control click in the space in the dock between the apps and the other stuff and there's your option for pinnig - left, right, or center. Just put it on center and that should work.

I'm sure there's a much simpler fix, but this one will work, especially if you want a transparent dock.
"Testuser" posted this reply in another post which maybe of help

"Try any of these commands from the Terminal:

defaults write pinning start
defaults write pinning middle
defaults write pinning end"

"defaults write pinning middle" would be the command you need
I just logged in remotely from work (in NT land, unfortunately) via ssh as the administrator, and typed in "defaults write pinning middle." Now, when I get home tonight, I'll be able to find out if it actually worked.

Thanks for the info.
I'm logged in as myself (which is not the administrative account) at the console now anyway, I'll definitely have to log out and then back in as the administrator to see if it worked.