DP 450, major problems, need help and advice badly!

pfm

Registered
Hello,

i awoke my previously flawlessly functiong G4 DP 450 from sleep tonight and got a grey screen. i did a hard restart. i got a folder witha flashing question mark. i booted from 9.1 CD and it booted fine, but my hard drive(s) did not show up on the desk top or in Disk First Aid. I have two internal 20 GB drives, one of those with two 10GB partitions. each drive has a copy of the OS on it. what is going on???!! why can't it see my HDs?

please offer me some advice on what to do next, and if it will be possible to get some very important files off the HDs. ok, looking forward to respones.

thank a million in advance.

pfm
 

knussear

Registered
I have had excellent results extracting important files from questionable drives with a program called Data Rescue. This program will extract information to a non affected drive, eg a zip or firewire and will leave your drives unaltered while it does so.

I have also been able to recoverd "lost" drives with the new Norton Disk Doctor.

Good luck
 

AlanCE

Registered
My blue G3 at work had a similar issue. First thing I did was boot from OS 9 CD and go to the Utilities folder and run Disk First Aid. As I recall, it didn't even see the drive.
So I booted from Norton Utilities CD. It saw the drive and found major errors and did a little repair but couldn't finish the repairs. I booted from the OS 9 CD again and ran Disk First Aid a couple of times. It repaired some things this time but still failed on a couple of errors.
Again I booted with Norton Utilities and ran Disk Doctor a few times. Each time the problems became fewer and less significant.

I highly recommend you get Norton Utilities and put it to work on this problem. You can start with booting from you OS 9 CD and running Disk First Aid, but I have little faith that will do the trick.
 

anerki

Registered
Hyo

I work in a computer store from time to time and we get loads of dead HDs; mostly PC but sometimes an Apple HD too.

What you should first do is check your HD for noises. Open your case, reboot the Mac and listen VERY carefully if there is ANY unusual noise ... If there is, you're f*cked (pardon my language) ... If it doesn't, sth went very very wrong, but still, it happens ... You should do as AlanCE says, try Norton and First Aid several times, they should be able to help each other out.

You can also try plugging in your HD on another Mac, since both HDs are invisible they might work on another Mac, perhaps sth is wrong with you firmware (perhaps, I would say BIOS but hey, we live in an Appleworld here
:D )

Anyway, I hope you can solve your problems ...

Greetz,
.anerki
 

scott

softer than ever!
I deal with this for a living. Too bad, huh?

Anyway, anerki is right. You need to determine if you drive is connected correctly to your machine, including power and data. Unplug the drive and reseat both connectors. Turn on machine with side open and listen for the drive to whir up. You can also put your hand on it and feel it for the tell tale whir and clicks. If your drive has power, move on to checking the ATA cable - make sure it is connected. Try using a different ATA bus if that doesn't work - like the zip tray (note - if putting a HD in zip tray, make sure drive is set as a slave).

Blah blah blah.... If you are convinced that the drive is mechanically sound and connected correctly in your machine (even a small bump could have scr**ed you.

If your drive does NOT spin on any power source, post again and someone'll tell you what to do. You may have a case of sticktion :eek:
 

scott

softer than ever!
Stupid Netscape can;t edit my own posts.


Anyway, if you are sure your drive is connected and functioning, move on to the software fixes as above (Norton 6, Drive 10 / Tech Tool.....).

Does Drive Setup on your OS 9 CD see the drive?
 

anerki

Registered
:)
What MIGHT work but I'm not totally sure: Change the HDs, the jumpers, make the Slave a Master and the Master a Slave. Perhaps by some mysterious way (probably curious Gnomes) one of the connectors of your Master HD doesn't give the Master signal, that's why none of the HDs work, both are Slaves ... Might work, but not sure. If they're Maxtor Quantum or IBM HD's I can tell you the setting of the pins to Slave and Master, otherwise try checking your HD's manual ...

Greetz,
.anerki
 

kevsteris

Registered
this may sound silly but here goes...this should be a last resort...
I had a drives lock up on me and this was the fix.

if the drive is getting power...the needle maybe frozen. I've seen this losts of times especially on quantum and maxtor drives.

1.take the drive out of you box
2. Hold the drive in one hand and give it a good rap with the palm of your other hand.

3. if this works....go out and purchase a new drive pronto. and get the info off of the old drive before it locks up for good...


good luck
 

scott

softer than ever!
Exactly. A good whack has saved me many a drive's data. But remember ONLY do that if the drive IS getting power and NOT clicking at spin-up. Otherwise you;re just beating your drive up.

Most repair software WILL see extremelly messed up drives. For example, in Norton you can say "Show missing disks" or even better - Apples Drive Setup should see any drive that is somewhat recoverable.
If these apps do not see a drive, chances are:
- No power or data connection to the drive (including wrong jumper configs)
- Mechanical failure
- Extreme drive software problems.

In the past one was able to go into Drive Setup or Silverlining and write a new driver to a disk without damaging the data. BUT... if you write an OS9 era HDD driver to an OSX partition, you are probably going to be forced to get your stuff off in OS9 and reformat anyway. Or you'll just be scr**ed.
 

wyvern

Guest
... you should try starting up holding down commmand and S to boot into single user mode. Then type fsck -y over and over again until it either can't fix anything more or it says that the disk appears to be OK. Me, I'm kind of leery of Norton, it's shafted me twice. (Reformat necessary before drive could be used.)
 

scott

softer than ever!
Norton used to be awesome, but now they can't seem to put out a product that would be reliable on more than one revision of machine. Norton 6 seems better at first glance. DO NOT use a norton prior to 6 on an X partition.

Tech Tool is my favourite for non-x partitions, even though it performs a whack of useless tests.

Tell you the truth, I no longer use a disk utility 'cept as a last resort. Seems to be more problems than they fix.

Anyway, pfm's problems will not let him boot into X to use fsck. I wonder if he gave up.

Hey PFM: I just re-read your posts. Having two individual drives go is REALLY unlikely, so check your power (you can use a multi-meter if you're brave). Trace your ATA cable(s) to motherboard. Try putting one of your drives into the zip tray (if you have nimble fingers). If you can narrow down your problem, you'll at least know how much to panic.


Sorry if we're being too talkative and not helpful enough.
 

sandbagger

Registered
one item we need to focus on here, I think, that is key - BOTH drives are not visible, and it happened at the same time. That pretty much rules out any help from Norton or even Disktools. and it's very doubtful that a mechanical failure would hit both at the same time, so don't start beating on the drives.

start with cables and connectors, as suggested; very common problem. next the master/slave settings from another post. One thing additional perhaps is just try one drive at a time, since both have an OS. Don't forget to set the master/slave jumpers for single drive.

Still dead? I believe you can switch the ribbon cables for the HDs and CD at their motherboard connector, since you know the CD works (I know this works in PC world). I would also try a different ribbon cable. oh- and try different power supply connections (like the one from the CD which we know works)

btw - didn't your 450 come with a single 30-gig HD? (mine did) if you still have that drive you might try it with the original cable.

good luck!
 

dsnyder

Registered
I've had volumes that became invisible that were magically resurrected by Diskwarrior (by Alsoft). When no other tool worked, Diskwarrior found and repair the volumes. I've used this tool extensively, and IMHO it's the best disk utility out there. The newer versions are safe for OSX HFS+ volumes.
 

scott

softer than ever!
sandbagger is totally correct - nobody clued in that this happened to two separate HDDs at once. This obviously leads to a wiring issue, a power issue, or a board issue - not a directory or software issue.

We batted this around all wrong because we didn't read the post correctly. Makes me look like an official idioteer.

Anyway, the person with the problem must have fixed it or recovered from the loss by now, 'cause they haven't posted on it since.
 

pfm

Registered
hey guys, thanks for all your replies, its good to know that help is always so close at hand. i would have posted this sooner, but i am in the depths of a huge Graphic Design project, no time for air. as it happens. i slept on the problem, tuned it on from a full shut down in the morning and it worked! no questions asked. as soon as this project is finished i am going to open the case and check all the connections to be on the safe side, and then do clean installs of 10.1 and 9.2.1 on seperate partitions for the duration.

thanks again fellows, much appreciated.

pfm
 

scott

softer than ever!
Right on.



Hey, if your a graphic designer, let me ask you a question-

What layout software do you use? I use Quark for page layout, Multi-Ad Creator for ad layout. I have to decide whether to go to Creator 6 from 4 or switch to Quark or InDesign for a LOT of people.
'
Creator is an EXTREMELY user friendly app, but Creator 6 (the new incarnation) is VERY machine intensive.

Just want to know what others use (besides Quark, which is $$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$)
 

elSilencio

Registered
Originally posted by pfm
tuned it on from a full shut down in the morning and it worked! no questions asked.

pfm
One of the first things in Apple hardware repairs is to turn off the computer and let it rest for 15 minutes without battery and power cord.

If this does not work you should try other things.

Norton is a good rescue and repair application and it depens on it how you use it. Many times you should turn OFF surface check and file check and let norton first check your partitions and directories. Check and repair these as long as no problems are found and only after this check your files.

This has worked for me many times.
 

dsnyder

Registered
) ?«?i]Originally posted by scott [/i]
sandbagger is totally correct - nobody clued in that this happened to two separate HDDs at once. This obviously leads to a wiring issue, a power issue, or a board issue - not a directory or software issue.[/QUOTE]

I forgot to mention, that situation in which I lost my volumes was after OS X froze and I had to force restart. All my volumes on all of my disks had disappeared, but it was not a wiring or power issue.
 

anerki

Registered
Macs are weird ... I had sorta the same problem some time ago (some weeks). I was trying to install OS 10.0.4 to prepare for the 10.1 upgrade and suddenly after installation my Mac just wouldn't boot anymore. It didn't just not start up, it just didn't start! No power, no click, no sounds, no lights ... Nothing. I unplugged the cable several times on both sides, used another cable, replugged the surge protector, ... Nothing worked. Anyway, it was late, I figured I was looking something over so I just went to bed. The morning, still nothing, I try all the same things, I even check if my cables send power and if the power is connected ... Anyway, I unplug the cable in preparation to take my Mac to store ... :-( Meanwhile, it was early, I go to get breakfast and bring it up, I decide to try it one last time and I plug the cable again. It works ...

Anyone has an idea of what was happening? Is my Mac possesed? Need I get an exorcist?

Greetz,
.anerki
 
Top