Dual 800 not running at full speed

ulrik

Registered
OK, three days back I finally got a dual 800 G4 Quicksilver (it was a damn struggle to get that thing!) and I am working on it for some time now.
But I have a little problem under OS X. The OS does not use the processors as it should. Example: when I render in Cinema 4D XL R7.1, both processors are only used to about 70%. This is not what I except. When I render something, I want them to be used as much as possible. Under classic, everything is fine, but not under OS X!
First I thought the unofficial 10.1 I am running (no comments on that, please) might be the reason, so I made a new, clean install of 10.0.3 and updated it to 10.0.4. Still....processor heavy apps only use the processor up to 70%. Both the top command and the processor load display show this. When I called Apple, they guy tried to tell me that this is not possible. But well....it happens here! I asked him if this would be a reason to return the Mac. His answer was that when they can confirm the error, yes, but as soon as they install MacOS 9.2, they will tell me it can't be hardware....so, does ANYBODY have a similar problem? I want those missing 1/3 of processing power under OS X!!!

ulrik
 

Matrix Agent

Masochist Mascot
Possibly it is part of the multi-tasking aspect of OSX. The other clock cycles may be reserved for the OS. Thats just speculation. Try Apple's support forums?
 

rharder

Do not read this sign.
Are you saying that rendering the same scene on OS 9 you get 100% utilization of both processors? How can you tell?

You'll rarely see 100% utilization of both processors if you're doing memory-intensive tasks, because there's only one pipe to the memory, and that's shared by the processors. That causes one processor to wait while the other fetchs/writes data.

This is a problem on all run-of-the-mill MultiProcessor computers that run Mac OS X, Windows NT/2000, Linux, etc. Clever caching helps a good deal, and some tasks don't require a lot of memory access, so you do occasionally see all processors maxed out, but not often.

-Rob
 

ronin_X

Registered
u see a good implementation of render from a single processor to a double?
u have try whit lightwave 6.5?
waht kind of video card u have on that monster?
other programs like photoshop or premiere work better whit a double proc?

thank u 4 answer and sorry 4 my bad english!!!!
 

ulrik

Registered
No, I can't tell if the same scene gets 100% from both CPUs under OS 9. IIRC OS 9 is not MP-ready.
My concern is, that on any Mac, when I run Cinema 4D on ANY other Mac under OS X, be it MP or not, the app from time to time reaches the 95% mark. But on this machine, it just never breaks through 70%...this is what bugs me....maybe the processor load display is just wrong? I used both the one coming from apple and a third party one, called LoadinDock. I haven't tested it with the top command, but IIRC top doesn't tell you the load on the different processors. It's just irritating as hell to see that - if I believe the processor load display - this expensive-as-hell Mac isn't used at full capicity. Something I just can't imagine how this could happen.
 

rharder

Do not read this sign.
A single-processor computer will hit 100% utilization because it doesn't have anything to contend with, except maybe waiting for network data or something like that.

A multi-processor machine running OS X or any other normal OS still has to share memory which means that you'll rarely see 100% utilization of both processors at the same time on memory-intensive tasks and some other kinds of tasks.

In your case it sounds like the two processors are fighting it out and each settle at 70% utilization. You could think of that as 140% utilization of a single processor. That's pretty good.

A second processor never gives you double performance - it just increases performance for some tasks. Be happy. It's like you've got a 1.1Ghz G4 for rendering. Sort of.

-Rob
 

ulrik

Registered
hmmm...when I run the same scene on a Dual 450 G4, both processors tend to hit the 90% limit often...I still think that maybe there is a bug in the LoadInDock-software....it's the same when using the TempInDock on a Cube. This Dockling shows you the temperature of the processors, on a dual machine even both temperatures, in the dock. On my cube, it shows 99,9° celcius....maybe due to the lack of a heat sensor in the cube ;)

ulrik
 

.dev.lqd

Angry Member
You might try loading up distributed.net, which has =extremely= optimized code. It will max out both processors unless there's some hardware limitation. And, if it proves to peak at 70 and hold... then there may be an error in the load monitors your using. Let us know.
 
Top