Dvd Ejects Disk, Will Not Run It.

schuyjak

Registered
G3 IBook, Sony comdo drive.
OSx Jaguar 10.2 with all updates and security patches.
The drive does play CDs but will not play DVDs.
IT did play DVDs in the past, I haven't used it to play CDs or watch DVDs for some time.
I bought the Tiger OS DVD. When I put the disk in the drive, it stays in and spins up and then is ejected.
I put a music CD in and it played. Then I tried a movie DVD that worked in it before and it was ejected. I did a lot of troubleshooting, ran the repair disks, to no avail. Apple had an update that side it would resolve DVD issues. I downloaded it, but it didn't work.
I ended up doing a clean install of the OS and the DVD still will not work. Should I trash the DVD software and then reinstall it? Would opening up the Ibook and unpluging the drive and the pluging it back in work.
Apple support was no help at all.

Thank You for your help
 

perfessor101

Registered
schuyjak said:
Would opening up the Ibook and unpluging the drive and the pluging it back in work.
A better plan, assuming you are in warranty or under AppleCare is taking your Book to the nearest Apple Store for repair. It sounds as if the DVD function of your SuperDrive has failed. It is quite common for SuperDrives to partially fail and less common for one to completely fail according to an Apple Tech I know.
 

fryke

Moderator
Staff member
Mod
G3 iBook. No SuperDrive. Probably no warranty either (that iBook's a bit old...).
 

schuyjak

Registered
It's around 2 yrs. old. It's almost never be used to play media, so the CD/DVD drive really shouldn't have a mechanical problem. I find that it doesn't.
After Google searches I found it's a common problem that only one part fail. I downloaded a tool from Version Tracker and it helped me identified what was going on. New drivers won't help. It seems it has something to do with permissions.
Meanwhile tonight I ordered a external usb CD/DVD drive, so I'll be installing Tiger in 5-7 days... It cost less than the bench charge at the Apple Store. Hopefully Tiger will fix the drive but I'm not getting my hopes up.
I'm pretty new to Mac troubleshooting a major problem. Apple support is not easy to wade through.
Although it didn't fix the drive, when running MissingMediaBurner software, it runs a Darwin logging and displays everything the computer is doing including error messages. Those error messages helped with searching Apples' knowledge base. Since a clean install of the Jaguar OS didn't fix the problem it may be the drive lost it's DVD firmware somehow. So I'll try that route next.
 
Top