Dvd player suddenly stopped working osx 10.4.8

kriz105

Registered
Hi All

Got a problem i cant seem to work out.

Suddenly my DVD player has stopped working. I place the disc into the drive and i get a spinning sound and out comes the disc! Automatically ejects.

Has anyone experienced anything similar? Can you help?

Regards
Kriz105
 
Hard to know instantly. There are a couple of diagnostic things you could try to rule of things that it is not.

1) Are you attempting to play discs that are region locked?
As you probably know, you can only play USA discs in the USA, and European discs in Europe, etc. Apple DVD players give you I think 5 changes of the region code before it locks you in, preventing you from playing discs from any region other than the last disc played.

2) Bad optical drive?
Have you tried burining a DVD disc and/or copying files from a data DVD disc (CD-brining doesn't count -- must have tried to burn/use a DVD disc to rule this possibility out)

3) Bad media?
I'm certain you've already tried this, but always good to try different discs. A good idea is to try playing a home-made DVD movie in DVD player. that way you know for sure that it has no restrictions.


Those steps would make it less likely to be a hardware issue, and more likely to be a software issue. For software issues, the only thing I can really think of is to create a new, dummy account on your Mac and try playing a DVD in there. You could also try the old repair permissions, but I doubt that will help. :S


are you using a MacBook Pro by any chance? I ask because my MBP's DVD drive has been nothing but trouble since I got it.
 

kriz105

Registered
Adding a new account was a good idea! sorry didnt think of it myself, the DVD player is now working in the new account.

Thanks i can now sort out.

Many thanks
 

dedukes

Registered
I just encountered exactly the same problem. Recently upgraded my ibook g4 and my girlfriend's powerbook g4 from 10.3.9 to 10.4.8. Some issue on both computers. When I pop in a DVD, DVD Player opens, but it says "unsupported media." No visible DVD on desktop. I created a new account in my computer and it works fine there. CDs work fine.

How do I fix the issue in my original account?
 
Top