Eclipse 3.1 changes jvm.cfg permissions?

zepto

Registered
Anyone know how eclipse changes the jvm.cfg properties, or more specifically I can 'disable' this feature.

When launching Eclipse as a normal user the first time all is fine. However, if you shut down Eclipse and then re-launch it it fails with a message no JVM found.

Seems that somewhere in the Launch process Eclipse is changing the jvm.cfg permissions to exclude normal users from having read access to jvm.cfg. Which is effectively disabling Java (and Eclipse)?

Thanks
Zepto

PS. Have posted a previous message, but it is pretty old now and not detailed enough.
 

zepto

Registered
Thanks for the response Viro,

I don't actually know exactly what the jvm.cfg file does. It does appear though that if a normal user doesn't have read access to this file then Java complains about no JVM found?

This is irrespective of eclipse afaik. Basically if I run java -version as a 'super' user it returns the appropriate version. If I run the same command as my 'normal' user it fails reporting no JVM?

Any suggestions?

Regards
Zepto
 

ljfong

Registered
I have had the same problem and I figured out that the correct permission for the jvm.cfg file should be rw-r--r--, however, if java is ever run by a non-root user, the permission of this file is switched back by something into rw-------. Therefore the file is not readable and regular user gets error message "no virtual machine is found". I tried using chflags schg into the file, the permission stayed, but instead of trying to change the permission back to the wrong one, the same culprit just created multiple copies of jvm.cfg in the directory with names like jvm.cfg,298, jvm.cfg,301,...and so on. Very annoying indeed. Now, what is the culprit? I have no clue.
 
Top