Epson Stylus Photo Rx500 Installation Problem

Amarillo

Registered
First, my scanner wouldn't work, so I reinstalled the driver from the epson site. Then, iPhoto would not load on my powerbook OS X. It opened but wheel span endlessly. I took drastic measures: I did a find for "epson" in my hard drive and deleted everything that came up, since this is the only epson product i connect to my computer. Then I reinstalled again, and copied all my photo files into a new library and that solved that problem, so now my iphoto and scanner are working, but now my printer won't print!! In the set up utility when i click "add printer" mine is not listed. I've tried reinstalling again to no avail. Epson support just keeps saying to reinstall. Any ideas about what's going on here? Thanks!

 

tumbleguts

Registered
• First thing, make sure that you have the right Epson Driver for your OS.
(I say this because I had a lot of trouble with my Epson RX510 when Panther changed from 10.3.4 to 10.3.5 - needed new driver and scanning software update.)

• When setting printer in 'print utility' - you must change the drop down menu to "EPSON USB". Don't use normal USB or the driver might not be listed or set properly. If you don't 'set' the driver in print utility - applications will not be able to specify the printer - and you cannot print!

• After installing software such as this - you should run 'repair permissions' in disk utility. This will ensure that the installer has correctly configured the new software/drivers - so there is no adverse effects on other applications.

Other than that - I don't know.
My Epson RX510 has been the best thing I've ever I've ever brought!
Few troubles - fast scanner - accurate colours - and drop dead stunning prints.
Nothing more to say...
 
Top